Drag and drop (to load file) into browser window not permitted outside the area currently occupied by an HTML element.

Status

()

Core
XUL
P3
minor
ASSIGNED
18 years ago
14 years ago

People

(Reporter: Val Sharp, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Trunk
Future
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.6 [en-gb]C-CCK-MCD NetscapeOnline.co.uk  (Win98; I)
BuildID:    2000101014

Loading a new document by dragging and dropping the file into the browser window 
will only work if the drag and drop is into an area occupied by the HTML element 
of the current document.
If the HTML element is less than the viewport, then only that area of the 
viewport will allow drag and drop, while the remaining area will not.

Reproducible: Always
Steps to Reproduce:
The testcase is simply an empty HTML document where the HTML element has the 
following style:

  html {height:100px; width:200px; border:thick solid green}

First load the testcase, and then try dragging and dropping any HTML file into 
the browser window.
Notice that this is permitted only within the (green) border area of the current 
HTML element.
                       

Expected Results:  One should be able to drag and drop files into any part of 
the viewport
(Reporter)

Comment 1

18 years ago
Created attachment 17779 [details]
testcase for D&D outside current HTML element area
(Reporter)

Comment 2

18 years ago
Further observations:

Drag and drop of file onto M18 shortcut icon will start up M18, but the browser 
won't load the file; the browser comes up empty.
And it will not allow drag and drop into the browser unless it already contains 
a document.

Same result occurs if one starts up M18, with an online page as default start up 
page, and one stops the connection - no document therefore no drag and drop.

Wondering if this is connected to #5569

Comment 3

18 years ago
->pinkerton
Assignee: trudelle → pinkerton
(Assignee)

Comment 4

18 years ago
of course, this is by design. obviously if you wanted to drag to the personal
toolbar, for example, it should add a bookmark there not load the page.

only the content area is a drop site for a file. If you disagree with the
reasoning, it's an XPApps problem, not a DnD problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 5

18 years ago
Um, Mike, I think the point of this bug report was that it should be the 
content area that is the drop site, and should not depend on what the actual
contents of the content area are. (In the example, you can only drop into
part of the content area, because the HTML element does not cover the whole
viewport/content area). But Valerie can reopen if she would like.
(Assignee)

Comment 6

18 years ago
wow, you're right. now i understand, and I'm utterly baffled. However, it's
still fairly low priority.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Assignee)

Updated

18 years ago
Severity: normal → minor
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → Future
(Reporter)

Comment 7

18 years ago
If it were just that one could only D&D into an existing root element area of 
the content area, then I would agree that it's minor, and it's not a problem 
that's likely to occur very often.

However, not being able to D&D onto the Mozilla icon to start up and open a file 
seems a little more serious.
(Assignee)

Comment 8

18 years ago
that's a separate issue, please file a different bug -- and that has nothing to
do with drag and drop w/in mozilla.
(Reporter)

Comment 9

18 years ago
Is it not a related problem?

Mozilla starts up OK, but the HTML file doesn't load - Mozilla remains with an 
empty content area, and will not allow drag and drop into the content area.

The problem seems to be that Mozilla will not load a document by drag and drop 
into the content area unless there is already a document in that area - whether 
it's on Mozilla start-up by drag and drop, or after an interrupted transfer to a 
start-up page, or simply into an area of the content area not currently occupied 
by a root element.

Apologies if this is the wrong component - what would be the right one?
(Assignee)

Comment 10

18 years ago
the component for dragging files onto the app's icon to load them would be
xpApps, and would probably go to law@netscape.com. FWIW, this works on mac.

Comment 11

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707

Works for me. I can drop an html file both in the green area or in the other space
You need to log in before you can comment on or make changes to this bug.