Sending emails is slow when profile stored on network drive

RESOLVED DUPLICATE of bug 558528

Status

--
major
RESOLVED DUPLICATE of bug 558528
9 years ago
6 years ago

People

(Reporter: wildfire, Unassigned)

Tracking

({perf})

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupme?)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.6) Gecko/20100628 Ubuntu/10.04 (lucid) Firefox/3.6.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.10) Gecko/20100512 Thunderbird/3.0.5

I have a number of machines, running either Thunderbird 3.0.5 or Thunderbird 3.1.

The 3.1 build identifier is: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.4) Gecko/20100608 Lightning/1.0b2 Thunderbird/3.1

The 3.0.5 build identifier is: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.10) Gecko/20100512 Thunderbird/3.0.5

The profile is stored on a network (Samba) share, as part of a roaming profile.

The IMAP server is dovecot 1:1.0.15-2.3+lenny1

When composing a message, sending it can take betwen 15 - 45 minutes.

What appears to be happening is that every IMAP account (either 3 - to 21) is being checked first, and *then* sending via SMTP is happening.

(I have tshark network captures illustrating this).

Additionally I have a (single) machine configured with 21 IMAP accounts using Thunderbird 3.0.5. It's account profile is stored on the local (C:) drive.

Sending and composing an email takes 15 - 45 SECONDS (order of magantude difference).

Reproducible: Always

Steps to Reproduce:
1. Compose email
2. Click send.
3. Wait 15 to 45 MINUTES (when local folders are stored on Network) whilst "Looking up server <SMTP server>" appears.


Expected Results:  
Mail should be sent, via SMTP, first in under a minutes

Updated

9 years ago
Keywords: perf
Whiteboard: dupme?
Version: unspecified → 3.0
(Reporter)

Comment 1

9 years ago
I have three test machines (3.0.5 with profile on network drive, 3.1 with profile on network drive and 3.0.5 with profile on local drive); the version is not the issue.

Thus I have upped it to 3.1

The location of the profile seems key.
Version: 3.0 → 3.1
(In reply to Anand Kumria from comment #1)
> The location of the profile seems key.

yes. it would be

Are you still seeing this problem when using a current version (7 or newer)?
(In reply to Wayne Mery (:wsmwk) from comment #2)
> (In reply to Anand Kumria from comment #1)
> > The location of the profile seems key.
> 
> yes. it would be
> 
> Are you still seeing this problem when using a current version (7 or newer)?
Flags: needinfo?(wildfire)
Anand doesn't respond. I'm going to assume this is a dup of bug 558528
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?(wildfire)
Resolution: --- → DUPLICATE
Duplicate of bug: 558528
You need to log in before you can comment on or make changes to this bug.