Tab closes unexpectedly, when clicking on it (touchpad: synaptics driver sends middle-click instead of left-click)

RESOLVED INVALID

Status

()

Firefox
Tabbed Browser
--
critical
RESOLVED INVALID
8 years ago
7 years ago

People

(Reporter: Fabian Vallon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.6) Gecko/20100628 Ubuntu/10.04 (lucid) Firefox/3.6.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.6) Gecko/20100628 Ubuntu/10.04 (lucid) Firefox/3.6.6

When switching between 2 existing tabs, the tab I want to switch to unexpectedly closes. No error message shown whatsoever, the crashed tab is listed in History->Recently closed tabs. Unfortunately i have no idea how to reproduce this. It happens frequently, but is not restricted to the case, when the second tab is still loading.

Reproducible: Couldn't Reproduce
Duplicate of this bug: 615093
Does the same happen with Safe Mode and all extensions disabled?

http://support.mozilla.com/en-US/kb/Safe Mode

Comment 3

7 years ago
(In reply to comment #2)
> Does the same happen with Safe Mode and all extensions disabled?
> 
> http://support.mozilla.com/en-US/kb/Safe Mode

Yes, I just tested this. 

It seems that I can reproduce this now quite quickly. I opened 4 tabs with different urls, and it took less than 50 clicks to have all but one tab disappear - just by switching between them.

I could reproduce it also using a 8-line local html-file with just the basic tags.

Comment 4

7 years ago
> > Does the same happen with Safe Mode and all extensions disabled?
> > 
> > http://support.mozilla.com/en-US/kb/Safe Mode
> 
> Yes, I just tested this. 
> 

I also tested that
-this happens also when in Private browsing mode and
-this happens also with a new, clean profile

What else can I do to study this problem? 
I'm also willing and able to run non-stable/debug-versions on this laptop, if needed.
Do you see an error in the Error Console once that happened?
(Reporter)

Comment 6

7 years ago
i guess it could be a gtk bug. same problem appeared to me when using pidgin with chat tabs. can anybody confirm this with another gtk application ? my gtk version is libgtk2.0-0 / 2.20.1-0ubuntu2+menuproxy

Comment 7

7 years ago
(In reply to comment #5)
> Do you see an error in the Error Console once that happened?

No, error console is clean.
I also just upgraded to the latest nightly, but that didn't help either.

BUT, when I did the tab-change with the keyboard (changed focus to tabs-row with tab-button and then changed active tab with left/right -arrows, there were NO PROBLEMS, so it seems to be related to mouse-event handling.
Teemu, on which platform are you on? Could it be the same issue as what Fabian has investigated?
(In reply to comment #6)
> i guess it could be a gtk bug. same problem appeared to me when using pidgin
> with chat tabs. can anybody confirm this with another gtk application ? my gtk
> version is libgtk2.0-0 / 2.20.1-0ubuntu2+menuproxy

Fabian, does it also happen with a new user account on Linux?

Comment 10

7 years ago
> > version is libgtk2.0-0 / 2.20.1-0ubuntu2+menuproxy
> Teemu, on which platform are you on? Could it be the same issue as what Fabian
> has investigated?

I'm on Ubuntu 10.10, with latest updates. libgtk2.0-0 / 2.22.0-0ubuntu1


> Fabian, does it also happen with a new user account on Linux?

I created a new user account to test this. The new account uses the default "Mozilla Firefox for Ubuntu canonical - 1.0", which shows version 3.6.12. 
And the problem is showing also with this setup.
Karl, do you know if that could be a GTK bug?
Firefox's tabs only depend on GTK for mouse click coordinates and for themed drawing, so I wouldn't have guessed a GTK bug.  pidgin would use quite different code, so if it's the same bug, I would expect more than just tabs to be affected.

Does the problem still happen with browser.tabs.closeButtons set to 0 (in about:config)?

Comment 13

7 years ago
> Does the problem still happen with browser.tabs.closeButtons set to 0 (in
> about:config)?

Yes. I have tested all values 0-3 for browser.tabs.closeButtons, no change in behaviour. 

>   pidgin would use quite different code, so if it's the same bug,  
> I would expect more than just tabs to be affected.

I haven't used Pidgin (it was Fabian), but I _do_ have also another mouse-related problem with Firefox. I filed also that one here: #615095. It's about unexpected, random page-url changes that happen when handling mouse-clicks on forms/ajax-applications. That might be somehow related...
A spurious middle click would close tabs and also could cause symptoms like bug 615095.  (Closing tabs on middle click is quite counter-intuitive on a system where the normal action is close, and unnecessary when there are close buttons everywhere, but that's another issue I guess.)
(In reply to comment #14)
> the normal action is close

Er, I mean normal action is to paste the selection.

Comment 16

7 years ago
(In reply to comment #14)
> A spurious middle click would close tabs and also could cause symptoms like bug
> 615095.  (Closing tabs on middle click is quite counter-intuitive on a system
> where the normal action is close, and unnecessary when there are close buttons
> everywhere, but that's another issue I guess.)

Hi,you absolutely right - what I'm experiencing here is exactly what would be expected from a middle-click. 
But, on my Acer Extensa 5220 I use the touchpad, and although it has the "top-right-corner double-tap" as middle-click -functionality, I'm not doing that by accident in this case. I use the "hard-key" (separate from touchpad) to left-click... 

But as said, these symptoms fit a bit too well to middle-clicking, so probably it IS the middle-click event handler that is triggered. The question now is, why it is triggered every now and then. I.e. if this is related to a recent change in Firefox (3.6.xx / 4.0bx), gtklib, or even touchpad-driver. 

I pretty much accept all updates for Ubuntu, so it's hard to say if, for example touchpad-driver was modified recently. I can only say that I first noticed this problem after upgrading to 4.0b7 (from 3.6.x). I have used previous versions of Firefox without this problem for a couple of years on this laptop.

Comment 17

7 years ago
> But, on my Acer Extensa 5220 I use the touchpad, and although it has the
> "top-right-corner double-tap" as middle-click -functionality, I'm not doing
> that by accident in this case. I use the "hard-key" (separate from touchpad) 
> to left-click... 

And just to be sure, I disabled touchpad-mouseclicks from Preferences->Mouse->Touchpad - it did not change the situation - this phantom middle-click still fires every now and then.
Could this depend on if the clipboard contains data or is empty?

Comment 19

7 years ago
(In reply to comment #18)
> Could this depend on if the clipboard contains data or is empty?

Don't seem to depend on that. I tested it with having data in clipboard, and also after clearing it with "xsel -bc". No change.
"NSPR_LOG_MODULES=Widget:5 firefox -no-remote |& grep Button" will print which button GDK thinks was pressed.

It might also be interesting to play with setting
Option "EmulateMidButtonTime" "0" for the synaptics driver (or perhaps there's similar "Touchpad" UI) to see if that disables middle button emulation, and whether that improves things.

Comment 21

7 years ago
(In reply to comment #20)
> "NSPR_LOG_MODULES=Widget:5 firefox -no-remote |& grep Button" will print which
> button GDK thinks was pressed.
> 
> It might also be interesting to play with setting
> Option "EmulateMidButtonTime" "0" for the synaptics driver (or perhaps there's
> similar "Touchpad" UI) to see if that disables middle button emulation, and
> whether that improves things.

So, this is what GDK thinks, what was pressed at the time when a tab was closed unexpectedly:
-1216226912[b7617060]: Button 2 press on b0fc69d0
-1216226912[b7617060]: Button 1 press on b0fc69d0
-1216226912[b7617060]: Button 2 release on b0fc69d0
-1216226912[b7617060]: Button 1 release on b0fc69d0

So, it really is the middle-click showing there (and I'm clicking just with the left button). There weren't any extra Button 3 -presses in the output (which could have brought middle button emulation).

My touchpad driver is "SynPS/2 Synaptics TouchPad" and I managed to change its attributes with xinput. I also experimented with EmulateMidButtonTime set to zero, but it had no effect on the behaviour - the Button 2 still showing.
The X protocol events can be traced using xtrace
http://packages.ubuntu.com/maverick/xtrace

or simpler would be to run xev and click on the xev window several times attempting to reproduce.

Comment 23

7 years ago
Hello, 
after Karl pointed me to right direction to play with Synaptics touchpad driver
settings and xinput, I ran into this:

https://bugs.launchpad.net/ubuntu/+bug/636720 

And unfortunately I made the same mistake as the poster of that one - to first
blame Firefox, when the problem was (is) deeper. I have confirmed with the
"xinput test <device>" that I get the middle-click also outside Firefox.

Fabian's original report was on 10.04, so I'm not sure if this Bug can be
closed yet, but I think we can wrap this up on my part. Thank you all for your
help.
Sounds good. And thanks for your help Teemu. Good to know that your issue is also a Linux one, as stated earlier by Fabian. Lets close this bug than in favor of the bug report on launchpad.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Summary: Tab closes unexpectedly, when clicking on it → Tab closes unexpectedly, when clicking on it (middle-click is send instead of left-click)
(Reporter)

Comment 25

7 years ago
Touchpad + synaptics driver here too.
Summary: Tab closes unexpectedly, when clicking on it (middle-click is send instead of left-click) → Tab closes unexpectedly, when clicking on it (touchpad: synaptics driver sends middle-click instead of left-click)
You need to log in before you can comment on or make changes to this bug.