extensive energy consumption / missing control of power

RESOLVED DUPLICATE of bug 400120

Status

()

Core
General
RESOLVED DUPLICATE of bug 400120
7 years ago
6 years ago

People

(Reporter: gw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.1) Gecko/20090624 Firefox/3.5

While I'm regulary using tabbed browsing, i find Firefox to be the main originator of waste power consumption on my machine: Firefox uses about 40 - 80percent of the cpu-power (having 1,7GHz).
That's still the case, while I'm using several tools for blocking unnecessary features by Adblock, Flashblock and Noscript.

If we calculate the power consumption of Firefox on a broad base, we may find, that several power plants are just running for satisfying the energy hunger of Firefox and thus millions of tons of greenhouse gases are polluted this way.

The main issue is the problem, that Firefox while using several tabs or windows is mostly uncontrollable: if there are running 25 tabs, I need to close each one step by step to find out, if some site is having an extensive use of my power, and though the results are uncertain / unreliable.

A solution might be a tool for controlling / checking each tab / window for its power use, to investigate this way the originator of wasting energy.
In addition that tab / site may be send asleep while not in use /viewed.

On't know about power consumption of other Firefox-processes or features running over all tabs and windows and can't check or control that too and thus maybe there's also need of control.

Other processes on my machine may be managed by task managing / process control of the OS (Windows, Linux...) and thus stopped or suspended. But I find the main origin of energy consumtion, Firefox, now to be one uncontrollable black box of energy wasting.

In addition this issue applies on the instability of some site that goes uncontrollable and sometimes crashes Firefox.
The specific site ist out of several tabs often unidentifieable.
One is going to restart Firefox, restore the session and the origin of the crash is going - unidentified - to crash Firefox again.

Reproducible: Always

Steps to Reproduce:
1.open several tabs or windows while loading different webpages
2.watch the use of power
3.
Actual Results:  
continously using power without the ability of control

Expected Results:  
control and manage the use of power of different tabs and windows

Updated

7 years ago
Component: Tabbed Browser → General
Product: Firefox → Core
QA Contact: tabbed.browser → general

Comment 1

7 years ago
Before you start blaming FF as the source of global warning, have you considered the possibility that there are people that do not experience this ? I'm only seeing a few percentages of cpu-use.

Do you experience it also in Safe Mode ?
<http://support.mozilla.com/en-US/kb/Safe+Mode?s=Safe+Mode>

Note that this will disable add-ons, but not plug-ins, so you behavior might be a bit different.

Excessive cpu-use might be caused by :
- plugins, like Flash or Java
- addons (most people forget that some of them are doing something continuously in the background)
- javascript (and its garbage collection)
- background tabs (animation, Flash, JavaScript, automatic refreshes, whatever)

Using Adblock, Flashblock and Noscript already works a lot ofcourse.

Comment 2

7 years ago
PS : you can't measure power usage for a single tab. cpu-usage is already difficult enough for an application (and besides, the tabs all run in a single thread at the moment, so you can't separate them), but you can't measure how much the disk drive or graphics card or sound system or whatever uses on behalf of tab.

Comment 3

7 years ago
Currently only plugins are running in a separate process (in 3.6.6 only Flash, Sliverlight and Quicktime, 4.0 will run all of them). There is a project, Electrolysis, to run the content of the different tabs in separate processes too. If that happens, it might be possible to measure cpu-usage per tab. But if it will be implemented as threads, which is faster than the current 1-thread-for-all but still crash-prone, then it might still be impossible to measure cu-usage per tab.

https://wiki.mozilla.org/Electrolysis

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 400120
You need to log in before you can comment on or make changes to this bug.