window.open doesn't respect windowName, new tab opened every time

REOPENED
Unassigned

Status

Firefox for Android Graveyard
General
REOPENED
8 years ago
8 years ago

People

(Reporter: Chwiej Pawel, Unassigned)

Tracking

Trunk
x86
Windows XP

Details

Attachments

(1 attachment)

TC
1.01 KB, text/html
Details
(Reporter)

Description

8 years ago
User-Agent:       Opera/9.80 (Windows NT 5.1; U; pl) Presto/2.6.30 Version/10.60
Build Identifier: Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:2.0b2pre)  Gecko/20100705 Namoroka/4.0b2pre Fennec/2.0a1pre

Maemo5
Gecko/20100705


Reproducible: Always

Steps to Reproduce:
1. Open attached TC
2. Tap on 'click for google' button
3. Switch back to previous tab
4. Tap again on 'click for google' button

Actual Results:  
New tab with google is being opened


Expected Results:  
Browser should use previously opened tab instead of opening a new one
(Reporter)

Comment 1

8 years ago
Created attachment 456038 [details]
TC
It works for me on a daily build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
This is half-done here. The browser does use the previous tab, but its still opened in the background. Therefore, the user doesn't know if anything has actually happened until they open the tab sidebar. 

Madhava, can we get your opinion on switch to tab here?
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---
You need to log in before you can comment on or make changes to this bug.