Input field within table acting funny

VERIFIED DUPLICATE of bug 50758

Status

()

Core
Event Handling
P3
normal
VERIFIED DUPLICATE of bug 50758
18 years ago
18 years ago

People

(Reporter: Joe Kelsey, Assigned: joki (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

18 years ago
On a Javascript-backed table containing input fields in the table elements,
"clicking" on the table fields does not put an active cursor in the field.  For
a two-character wide field, youmust type two characters before any are displayed
and then erase the last typed character to see the fields.

The actual code is behind a password-protected site, but I can provide the basic
page contents when needed.

Updated

18 years ago
Assignee: rogerl → joki
Component: Javascript Engine → Event Handling
QA Contact: pschwartau → lorca

Comment 1

18 years ago
We'll need to have a reproducible example to analyze the bug; preferably
a reduced testcase that you attach here (see "Create a new attachment" above)

Also, please indicate what build date you are using - thanks


In the meantime, from the description, I am reassigning to Event Handling,
as this is not a JS Engine issue - 
(Reporter)

Comment 2

18 years ago
I am trying to use the "Create a new attachment" link on the Bugzilla page.
Every time I enter the file name and a description, Bugzilla complains that I
need to provide a description.  This is whether or not I have any text in the
description field.  If your attachment link doesn't work, then how can I
actually submit the attachment?
(Reporter)

Comment 3

18 years ago
Mozilla Build ID: 2000101611, FreeBSD port of M18 from mozilla.org download.

Comment 4

18 years ago
Created attachment 18261 [details]
test attachment made on Linux MN6 10-18-09.

Comment 5

18 years ago
Joe-any way you could a) let us know what site it is (even with no password?) or 
b) copy/paste the code that is creating the problem?  Right now it seems a little 
hard to reproduce the problem since I can't seem to put my finger on the issue 
here.  If you are having trouble submitting an attachment with your current build 
of mozilla, perhaps a more recent build would help?  Or an older one?:)  Just 
tested the process on my linux box with a similar build to what you must be using 
with mo problem...


Thanks. -d
(Reporter)

Comment 6

18 years ago
I am using Mozilla build id 2000101611 built for FreeBSD.

This version refuses to allow me to "Create a new attachment".

Find a FreeBSD system to test a straight M18 build and then tell me whether or
not "Create a new attachment" works.

I e-mailed the attachment to joki@netscape.com.  The page in question is reached
through http://www.timekeep.net/

Comment 7

18 years ago
Joe, are you using a transparent proxy?  You might be running into the same 
problem with uploading attachments as I was on bug 54137.

Comment 8

18 years ago
Joe is this still a problem with the latest nightlies?

Comment 9

18 years ago
Due to lack of response and vagueness of bug report I am marking this INVALID.
Reopen if it still occurs in the latest nightlies and you can give us some more
information on the problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Reporter)

Comment 10

18 years ago
What are you talking about, "lack of response"?

I have responded to every single request for information.  I have sent you all
of the web pages you need to fix the problem.  I have never failed to respond to
the information requested.  Your latest response is nothing short of insulting
and rude.

If you need information, ask.  The bug is completely described and there is
nothing vague about the description.  If you don't understand the description,
ask me a question about it.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 11

18 years ago
Joe Kesley : This bug is perfectly described however
1) The build you were using is _old_, a lot of bugs have been fixed since build
20001016 against which you are reporting this problem.
2) Your last comment has been recorder on 2000-10-29, and two questions have
been asked :
- Do you have a transparent proxy
- Do you still see this in a recent nightly build
This is not what I call "answer all the questions"
3) Keyser Sosez is a bugzilla QA and he works hard to triage the bugs, so the
developers have an easier time fixing their bugs. It is common knowledge that
unconfirmed bugs that cannot be reproduced and that stay untouched for a long
time can be marked "worksforme" or "invalid" (doesn't really matter).
4) A bug can always be re-opened, and Keyser mentioned it in his comment.
The final word is this :
Bugzilla has to be kept clean. We (bugzilla QA's) work hard to keep it that way.
If you do not agree with our resolution rules, please see the documents in
http://www.mozilla.org/quality/help and mail whoever is responsible for them
with your concerns.
Don't hesitate to mail me for more informations, thank you for taking the time
to read this,
Fabian.
(Reporter)

Comment 12

18 years ago
No, I am not running a transparent proxy.

Yes, the bug is still present in the latest nightly I was able to build.
Unfortunately, the nightly builds stopped working on FreeBSD about a month ago.
 Therefore, I cannot actually test it on anything that I have access to.  The
last time I checked, shortly before 0.6 was released, it showed the identical
behavior on windoze.  You may want to try a windoze build and see if it still
shows that behavior.  Unfortunately, I do not currently have access to a windoze
platform.  The only platform I currently have access to is FreeBSD.

I am sorry that I missed the transparent proxy question.  I tried to answer the
other question about recent builds, but I cannot make a recent build work on my
platform.  Maybe if someone in Mozilla resurrected their FreeBSD test platform?
Joe: Could you mail me the test page at bug57706@damowmow.com">bug57706@damowmow.com please? I'll 
attach it and investigate. Thanks!

Comment 14

18 years ago
Joe any chance you could send Hixie the test page?
(Reporter)

Comment 15

18 years ago
Created attachment 21795 [details]
main entry--defines frames
(Reporter)

Comment 16

18 years ago
Created attachment 21796 [details]
navigation--top frame
(Reporter)

Comment 17

18 years ago
Created attachment 21797 [details]
bug is here--bottom frame
(Reporter)

Comment 18

18 years ago
see the attachments above.

Comment 19

18 years ago
I see the bug as reported when I load just the bottom frame.  I'm on Windows 
and using Mozilla 2001 011204.  Confirming and setting OS to All.  I'll try to 
make a testcase.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: FreeBSD → All
Hardware: Other → All
Whiteboard: jesse making testcase

Comment 20

18 years ago
Testcase:

data:text/html,<input type="text" size="5" style="text-align:right;">

*** This bug has been marked as a duplicate of 50758 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE
Whiteboard: jesse making testcase

Comment 21

18 years ago
VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.