bitmap font rendering problem on WinXP (overlapping letters)

RESOLVED FIXED

Status

()

Core
Graphics
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Ekanan Ketunuti, Assigned: jtd)

Tracking

({regression, testcase})

Trunk
x86
Windows XP
regression, testcase
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

(URL)

Attachments

(6 attachments, 1 obsolete attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1

wrong rendering if webpage use MS Sans Serif font. http://www.tfex.co.th/tfex/dailyMarketReport.html

Reproducible: Always
(Reporter)

Comment 1

8 years ago
Created attachment 456148 [details]
MS Sans Serif font rendering problem

Comment 2

8 years ago
Yes, I agree, this bug https://bugzilla.mozilla.org/show_bug.cgi?id=436788 has returned. I'm uploading simplified testcase... In 1.9.2, in 1.9.3 broken...

Comment 3

8 years ago
Created attachment 456557 [details]
Bad rendering of font MS Sans Serif in current Gecko 1.9.3
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk

Updated

8 years ago
Duplicate of this bug: 578887

Updated

8 years ago
Status: UNCONFIRMED → NEW
Component: General → Graphics
Ever confirmed: true
Keywords: regression, testcase
Product: Firefox → Core
QA Contact: general → thebes

Updated

8 years ago
blocking2.0: --- → ?
Summary: MS Sans Serif font rendering problem → MS Sans Serif font rendering problem (overlapping letters)
blocking2.0: ? → final+
Keywords: regressionwindow-wanted
John, can you take a look at this once we have a regression window?
Assignee: nobody → jdaggett

Comment 6

8 years ago
Created attachment 458491 [details]
testcase with more broken fonts

Mozilla/5.0 (Windows; Windows NT 5.1; en-US; rv:2.0b2pre) Gecko/20100719 Minefield/4.0b2pre

Seems all Type 1 Fonts are broken. I see this bug with
 "MS Serif", "Roman", "Small Fonts", "System",
 also "Script" and "Modern".

Updated

8 years ago
Attachment #458491 - Attachment mime type: text/xml → text/html

Comment 7

8 years ago
Created attachment 458492 [details]
testcase with more broken fonts

(this is the right one, sorry)
Attachment #458491 - Attachment is obsolete: true
(Assignee)

Comment 8

8 years ago
Tested trunk on Windows7, all the testcases look fine.  I suspect this is an XP-only regression related to the fix for bug 561304:

http://hg.mozilla.org/mozilla-central/rev/31c52b96e75e

Checkin date was 6/25.
(Assignee)

Comment 9

8 years ago
Created attachment 458536 [details]
screenshot, testcase with broken fonts on win xp

Mozilla/5.0 (Windows; Windows NT 5.1; en-US; rv:2.0b2pre) Gecko/20100712 Minefield/4.0b2pre (.NET CLR 3.5.30729)
(Assignee)

Comment 10

8 years ago
Yup, as suspected...

Rendering fine:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a6pre) Gecko/20100624 Minefield/3.7a6pre (.NET CLR 3.5.30729)

Rendering wankered:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a6pre) Gecko/20100626 Minefield/3.7a6pre (.NET CLR 3.5.30729)
(Assignee)

Comment 11

8 years ago
Created attachment 458554 [details]
testcase, bitmap fonts with both GDI and Uniscribe rendering

Clearly it's the GDI rendering path that has the problem, Uniscribe looks fine.
(Assignee)

Updated

8 years ago
Summary: MS Sans Serif font rendering problem (overlapping letters) → bitmap font rendering problem on WinXP (overlapping letters)
(Assignee)

Comment 12

8 years ago
The 1.9.2 Windows font code contains this comment:

// GetGlyphIndices is buggy for bitmap and vector fonts, so send them to uniscribe
// Also sent Symbol fonts through Uniscribe as it has special code to deal with them
if (!aFont->GetFontEntry()->IsTrueType() || aFont->GetFontEntry()->mSymbolFont)
    return PR_FALSE;

http://mxr.mozilla.org/mozilla1.9.2/source/gfx/thebes/src/gfxWindowsFonts.cpp#1555

Code to shunt bitmap/vectors fonts to Uniscribe wasn't carried over to the new gfxGDIFont code but since Uniscribe was enabled by default the bug was masked until bug 561304 forced us to use GDI on XP.
(Assignee)

Comment 13

8 years ago
Created attachment 458594 [details] [diff] [review]
patch, force bitmap fonts to uniscribe path

Fixes the wacky rendering problems but some fallback problems remain for MS Sans Serif, MS Serif and Courier.

Updated

8 years ago
Keywords: regressionwindow-wanted
(Assignee)

Updated

8 years ago
Attachment #458594 - Flags: review?(jfkthame)
Comment on attachment 458594 [details] [diff] [review]
patch, force bitmap fonts to uniscribe path

This looks fine (though all these contortions make me sad - we should be able to just use Uniscribe for all fonts!)
Attachment #458594 - Flags: review?(jfkthame) → review+
(Assignee)

Comment 15

8 years ago
Pushed to trunk
http://hg.mozilla.org/mozilla-central/rev/9a81894fc687
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Depends on: 628091
You need to log in before you can comment on or make changes to this bug.