Adjust default max tab width to match FF4 mockups

RESOLVED INVALID

Status

()

--
trivial
RESOLVED INVALID
8 years ago
5 years ago

People

(Reporter: mozbugz, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; en-US; rv:2.0b2pre) Gecko/20100705 Minefield/4.0b2pre Firefox/3.6.6
Build Identifier: 

It looks like the default on all platform mockups for maximum tab width is smaller than the current default.

This appears to be a cool 200px instead of 250px which was hardcoded in bug 574654. 

Need to update the base browser.css with this new tab UI style.



Reproducible: Always

Actual Results:  
.tabbrowser-tab {
  max-width: 250px !important;
}

Expected Results:  
.tabbrowser-tab {
  max-width: 200px !important;
}
(Reporter)

Updated

8 years ago
Blocks: 574654, 544823
Severity: normal → trivial
Component: General → Tabbed Browser
Keywords: uiwanted
Version: unspecified → Trunk
It's 210px of width.
Blocks: 560507
(Reporter)

Updated

8 years ago
No longer blocks: 544823
QA Contact: general → tabbed.browser
No longer blocks: 574654

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
What's the point of reducing the max width? This will degrade usability especially with the full title not being displayed in the title bar.
We are just following mockups. Someone from UX team should answer your question.

Comment 4

8 years ago
I guess you could argue there is a usability win in not having the tabs too wide. I mean, there is a reason for not having two tabs take up half the screen width each ... :)

Comment 5

8 years ago
The UX team actually wants to decrease the tab max-width.

The tentative mockups are tentative mockups.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(In reply to comment #5)
> The UX team actually wants to decrease the tab max-width.

That's what this bug seems to ask for.
(Reporter)

Comment 7

8 years ago
(In reply to comment #6)
> (In reply to comment #5)
> > The UX team actually wants to decrease the tab max-width.
> 
> That's what this bug seems to ask for.

Correct.  I don't care what the new size should be, but when we analyzed the mockups before, we were trying actually figure out what the new value should be, I thought it was 200, but I guess it should be 210, but whatever the new number, I opened this bug to get it updated.
Since I'm considering this wiki: https://wiki.mozilla.org/Firefox/Projects/New_Theme/Timeline as accurate one, this should be reopened. Current tabs are ridiculously long, which is more noticeably now that tabs are in title bar and bug 610561 is WONTFIX. Currently only FX4 has that long tabs, rest (IE9, Chrome and Opera) have them much shorter.
I have 15'6 laptop with 1368x768 resolution and 4 tabs are max. After that, tabs are beginning to shrink.
This seems to have been closed erroneously.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Requesting to block beta 10.
This is basically only bug that needs to be fixed. Frank, can you "fix" it, please?

Comment 12

8 years ago
Shorlander and his team need to provide guidance before anyone "fixes" anything here. Peter, cc'ing Frank isn't appropriate here because we're waiting on the UX team and either way this isn't going to happen for Firefox 4 (which is done.)
I talked with Alex about this and he agreed this shouldn't be closed, so I took that as confirmation. After all, Alex himself reopened this bug. I wouldn't do anything by myself without consultation with UX team.

Comment 14

8 years ago
we have the longest tabs among all browsers , to streamline the GUI i think this bug does hold some importance
Assignee: nobody → limi
Keywords: uiwanted

Updated

5 years ago
Assignee: limi → nobody

Updated

5 years ago
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.