OS/2 - Jiggly Text When Selecting in Browser Window

VERIFIED WONTFIX

Status

SeaMonkey
General
P3
minor
VERIFIED WONTFIX
18 years ago
14 years ago

People

(Reporter: Barry Marshall, Assigned: IBM Warpzilla Team)

Tracking

({helpwanted, relnote})

Trunk
x86
OS/2
helpwanted, relnote

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CMVC32753, URL)

(Reporter)

Description

18 years ago
Jiggly Text...  Sounds like a new Pokemon, right?  Not really.

Drag select some text in the browser window.  Notice how the font 
jiggles the characters to the right of what you select.

It doesn't crash the browser, but it's weird, since no other 
application I have does this.
(Reporter)

Comment 1

18 years ago
Oh, this is with 1020 on my usual TP770X, 1024 * 768 * 32 bpp, SDD.
(Trying out Mike's new template for bug reports).

Comment 2

18 years ago
SCREENED.  VERIFIED AS VALID.
Assignee: mkaply → mozilla
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: helpwanted
Whiteboard: CMVC32753

Comment 3

18 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 4

18 years ago
Wrong defect
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Re-confirmed still broken under 1114.
Behaviour is better under 1121.  The font now only jiggles when I'm using the
default monospace font.
...and happens with Courier New, but not with Courier.

Is this a Postscript vs. TrueType problem?

Comment 8

18 years ago
No, it's a bitmap font vs. non-bitmap font problem.
(Reporter)

Comment 9

18 years ago
So Mozilla doesn't like bitmap fonts?  I'm just looking to clean up the summary.

Comment 10

18 years ago
This is a permanent restriction caused by an incompatibility between the
Mozilla GFX layer and OS/2 GPI. The whole is more/less than the sum of the
elements...
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 11

18 years ago
If that's the case, then it should be noted as a Release Note for the next OS/2 
milestone build and subsequent releases.

I'll hold this bug in this state for Mike or Jeffrey to set Verify then.
Keywords: relnote
QA Contact: doronr → mkaply

Comment 12

16 years ago
verify.

we can't fix this.

Os/2 limitation
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.