crash [@ nsMsgGroupThread::~nsMsgGroupThread()] - [@ nsMsgGroupThread::SetMsgHdrAt] if issuing compact folder in 2 different IMAP folders fast enough

RESOLVED WORKSFORME

Status

Thunderbird
General
--
critical
RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: Jacques Amar, Unassigned)

Tracking

({crash})

x86_64
Windows 7
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.7) Gecko/20100701 Firefox/3.6.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.4) Gecko/20100608 Lightning/1.0b2 Thunderbird/3.1

On a large IMAP installation, I often delete and compact messages that I know I will not undelete right away. If I do this sequence fast enough in one IMAP folder and switch to another folder and do the same, I *sometimes* get a thunderbird crash - with a message saying compact already in progress. I think it started with 3.0.5 but I see this in 3.1

Reproducible: Sometimes

Steps to Reproduce:
1. Delete a bunch of email in one (large) IMAP folder
2. Compact folder
3. switch folder to another large IMAP (same server)
4. Delete
5. Compact
Actual Results:  
Get a message saying compact already in progress, then crash


Thunderbird automatically submits this also. Thought I'd create a bug
(Reporter)

Updated

8 years ago
Version: unspecified → 3.1

Comment 1

8 years ago
Hi Jacques. Can you post a couple of your crash report ids?
 https://support.mozillamessaging.com/en-US/kb/Mozilla+Crash+Reporter#Viewing_crash_reports
Severity: normal → critical
Keywords: crash
(Reporter)

Comment 2

8 years ago
That's a neat add-on!

Here's what I have on my home computer. Will check later on my work one.

http://crash-stats.mozilla.com/report/index/bp-32f03644-7f3e-484d-b19e-398cd2100706

Comment 3

8 years ago
Thanks Jacques!

(In reply to comment #2)
> http://crash-stats.mozilla.com/report/index/bp-32f03644-7f3e-484d-b19e-398cd2100706

0  	thunderbird.exe  	nsMsgGroupThread::~nsMsgGroupThread  	 mailnews/base/src/nsMsgGroupThread.cpp:68
1 	thunderbird.exe 	nsMsgGroupThread::`scalar deleting destructor' 	
2 	thunderbird.exe 	nsMsgGroupThread::SetMsgHdrAt 	mailnews/base/src/nsMsgGroupThread.cpp:139
3 	thunderbird.exe 	nsMsgGroupThread::RemoveChildHdr 	mailnews/base/src/nsMsgGroupThread.cpp:305
4 	thunderbird.exe 	nsMsgGroupView::OnHdrDeleted 	mailnews/base/src/nsMsgGroupView.cpp:710
5 	thunderbird.exe 	nsMsgDatabase::NotifyHdrDeletedAll 	mailnews/db/msgdb/src/nsMsgDatabase.cpp:724
6 	thunderbird.exe 	nsMsgDatabase::DeleteHeader 	mailnews/db/msgdb/src/nsMsgDatabase.cpp:1810
7 	thunderbird.exe 	nsMsgDatabase::DeleteMessages 	mailnews/db/msgdb/src/nsMsgDatabase.cpp:1753
8 	thunderbird.exe 	nsImapMailFolder::UpdateImapMailboxInfo 	mailnews/imap/src/nsImapMailFolder.cpp:2855
9 	xpcom_core.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:102
10 	xpcom_core.dll 	nsProxyObjectCallInfo::Run 	xpcom/proxy/src/nsProxyEvent.cpp:181
11 	xpcom_core.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:527

this crash is not a topcrash - on average less than 1 per day, but there appear to be a few people like Jacques who can reproduce. no evidence of this crash prior to 3.0b4 build 20090915181920, eg bp-65807ed3-1bbe-49c9-a6e2-9fa582091102, so perhaps this crash is a regression

test@ddns - appears to have tested several ways (so not asking anyone to test safe mode)
bp-557e0fc3-10bf-4bb2-a448-ca0552100621 3.0.5
bp-42c46feb-9eb6-4d73-862f-cf66b2100618 3.0.4
bp-4e473f9a-1d2e-4b2f-8772-82ac22100708 3.1
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: crash if issuing compact folder in 2 different IMAP folders fast enough → crash [@ nsMsgGroupThread::~nsMsgGroupThread()] - [@ nsMsgGroupThread::SetMsgHdrAt] if issuing compact folder in 2 different IMAP folders fast enough
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsMsgGroupThread::~nsMsgGroupThread()] [@ nsMsgGroupThread::SetMsgHdrAt]

Comment 4

6 years ago
Jacques, how reproducible is this if you use a current version?
Crash Signature: [@ nsMsgGroupThread::~nsMsgGroupThread()] [@ nsMsgGroupThread::SetMsgHdrAt] → [@ nsMsgGroupThread::~nsMsgGroupThread()] [@ nsMsgGroupThread::SetMsgHdrAt]
(Reporter)

Comment 5

6 years ago
A few versions back there seems to be a verification check that simply doesn't allow a compact if one is still active. No more crashes. Not reproducible.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.