nsPNGEncoder::mImageBufferReadPoint will be initialized after nsPNGEncoder::mFinished

RESOLVED FIXED

Status

()

Core
Graphics
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: timeless, Assigned: timeless)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [build_warning])

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
modules/libpr0n/encoders/png/nsPNGEncoder.h: In constructor ‘nsPNGEncoder::nsPNGEncoder()’:
nsPNGEncoder.h:101: warning: ‘nsPNGEncoder::mImageBufferReadPoint’ will be initialized after
nsPNGEncoder.h:94: warning:   ‘PRPackedBool nsPNGEncoder::mFinished’
nsPNGEncoder.cpp:51: warning:   when initialized here
(Assignee)

Comment 1

8 years ago
Created attachment 456248 [details] [diff] [review]
patch
Assignee: nobody → timeless
Status: NEW → ASSIGNED
Attachment #456248 - Flags: review?(jmuizelaar)
(Assignee)

Updated

8 years ago
Duplicate of this bug: 575708
Whiteboard: [build_warning]
Looks like this landed last week as:
  http://hg.mozilla.org/mozilla-central/rev/9c1ac55cd5b7
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.