If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Feedback button can not be moved or removed from toolbar (after restart)

VERIFIED FIXED in 1.1

Status

Mozilla Labs Graveyard
Test Pilot
P1
normal
VERIFIED FIXED
7 years ago
a year ago

People

(Reporter: FlashCode, Unassigned)

Tracking

Bug Flags:
in-litmus ?

Details

(Whiteboard: beta, ui)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1

Feedback button can not be removed from toolbar, when customizing toolbars. In fact it is removed, but if Firefox is closed and opened again, feedback button is still there.

Reproducible: Always

Steps to Reproduce:
1.menu View -> toolbars -> customize...
2.drag feedback button to new window, to remove it from toolbar
3.close firefox
4.run firefox
Actual Results:  
Feedback button is back.

Expected Results:  
Feedback button is not visible.
(Reporter)

Comment 1

7 years ago
I find a workaround: I just realized feedback is a plugin, and disabling this plugin removes feedback button.
But for me it's still a bug to not be able to remove button from toolbar, even if plugin is enabled.

Comment 2

7 years ago
Can't even banish it to the bookmarks toolbar. Comes right back after restart.
Status: UNCONFIRMED → NEW
Component: Toolbars → Test Pilot
Ever confirmed: true
OS: Windows XP → All
Product: Firefox → Mozilla Labs
QA Contact: toolbars → test-pilot
Hardware: x86 → All
Summary: Feedback button can not be removed from toolbar (after restart) → Feedback button can not be moved or removed from toolbar (after restart)
Target Milestone: --- → --
Version: unspecified → Trunk

Updated

7 years ago
Whiteboard: FF 4 BETA

Comment 3

7 years ago
That sounds like a logic bug in the code which adds the feedback button to the toolbar -- i dynamically add it on startup rather than hard-coding it into the XUL because the firefox team requested it that way.

It should be using a pref to ensure that once it adds it to the toolbar once, it doesn't try to add it again.
Priority: -- → P1
Whiteboard: FF 4 BETA → beta, ui
Target Milestone: -- → 1.1

Comment 4

7 years ago
Fixed in http://hg.mozilla.org/labs/testpilot/rev/d91d9770a625
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Flags: in-litmus?
verified fixed with recent build of TP on beta 6
Status: RESOLVED → VERIFIED
(Assignee)

Updated

a year ago
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.