Regression: -moz-transform fails in an inline-block in firefox 4 beta

RESOLVED DUPLICATE of bug 518172

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 518172
8 years ago
8 years ago

People

(Reporter: Jack, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

587 bytes, text/html
Details
(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:2.0b1) Gecko/20100630 Firefox/3.5.2
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:2.0b1) Gecko/20100630 Firefox/3.5.2

When elements are rotated within inline blocks, the element is rotated falsely as of firefox4, this works correctly in firefox3.6 and firefox 3.5.

See attached test-case.

Note highlighting the text in the test case will cause a correct display, but reverts to buggy display when the window looses focus.

Reproducible: Always

Steps to Reproduce:
1. Put at least two elements with inline-block next to each other.
2. Rotate contents (an inline element).
Actual Results:  
inline element's box is rotated, but the characters remain horizontal, nice effect, but behavior is more akin to writing-mode, albeit for any angle.

Expected Results:  
inline element is rotated along with the individual characters rotated as well, refer to previous versions of firefox for correct rendering.

When highlighting the text, I can get the text to appear as it should, both with the mouse (though this is trial and error and will take several attempts), and also through the find (ctrl+f) method.

This also occurs when a hover is placed on the span element, e.g. changing text color, when the window looses focus (simply by pressing alt+tab), the element is repainted falsely.
(Reporter)

Comment 1

8 years ago
Created attachment 456263 [details]
Testcase

Testcase for bug.
(Reporter)

Updated

8 years ago
Summary: Regression: -moz-transform fails in an inline-blick in firefox 4 beta → Regression: -moz-transform fails in an inline-block in firefox 4 beta
Severity: major → normal
Component: General → Layout
Keywords: testcase
Product: Firefox → Core
QA Contact: general → layout
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 518172
You need to log in before you can comment on or make changes to this bug.