Add-on count when sorted by Name incorrectly shows a bloated number

VERIFIED FIXED in 5.11.4

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
8 years ago
2 years ago

People

(Reporter: krupa, Assigned: jbalogh)

Tracking

Details

(Whiteboard: [z], URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
Created attachment 456324 [details]
screenshot-sort by name

user agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1

steps to reproduce:
1. Compare the add-on count between  https://preview.addons.mozilla.org/en-US/firefox/themes/?sort=name&unreviewed=on and https://preview.addons.mozilla.org/en-US/firefox/themes/?sort=updated&unreviewed=on

observed behavior:
when sorted by Name,counter shows 5388 add-ons where other sort options just list 729 add-ons
(Reporter)

Comment 1

8 years ago
Created attachment 456325 [details]
screenshot-sort by updated
(Reporter)

Comment 2

8 years ago
also happens for /extensions
Summary: Theme count when sorted by Name incorrectly shows 5388 add-ons → Add-on count when sorted by Name incorrectly shows a bloated number
(Assignee)

Comment 3

8 years ago
http://github.com/jbalogh/zamboni/commits/22256ca
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

8 years ago
Sadly, that page is much slower since we have no good indexes on translations.
(Reporter)

Comment 5

8 years ago
After the fix,sorting by Name lists three add-ons less than the other sorts.
Compare https://next.addons.mozilla.org/z/en-US/firefox/extensions/?sort=updated to https://next.addons.mozilla.org/z/en-US/firefox/extensions/?sort=name  

Let me know if you want this filed as a separate bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

8 years ago
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

8 years ago
(In reply to comment #5)
> Let me know if you want this filed as a separate bug.

I think you've filed that bug somewhere already.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.