Account creation: Error message is shown when starting to type in email address

RESOLVED DUPLICATE of bug 592382

Status

Cloud Services
Firefox Sync: UI
RESOLVED DUPLICATE of bug 592382
8 years ago
7 years ago

People

(Reporter: Wladimir Palant (for Adblock Plus info Cc bugzilla@adblockplus.org), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Steps to reproduce:

1. Go to the form to create new account.
2. Type in email address (foobar@example.com).

Expected results:

No error message

Actual results:

An error message is shown as soon as you start typing. It only disappears when you are almost finished typing.

This is a case where validation should be performed on blur, not on input.
Yeah, this could be better.  The flipside is that in the custom server case, there's no ToS checkbox, so the next button stayed disabled until you exited.

What we really want is validation to happen, but not update UI on failure unless we're blurred.
I think we've fixed this now... Philipp?
Yep, fixed.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 592382
You need to log in before you can comment on or make changes to this bug.