Wrapper scripts should propogate exit codes

VERIFIED FIXED

Status

SeaMonkey
Build Config
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Raja Harinath, Assigned: cls)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.12-20smp i686; en-US; m18) Gecko/20001023
BuildID:    2000102308

The wrapper scripts 'mozilla' and 'run-mozilla.sh' do not propogate
the exit code of the wrapped program (e.g. mozilla-bin).  This
prevents, say automatic respawn script that try to restart Mozilla
if it crashed for some reason (e.g., if it exited with Sig11, the
exit code would be 139 -- indicating that it was an unasked-for exit).


Reproducible: Always
Steps to Reproduce:


Actual Results:

Expected Results:

A patch will be attached to the created bug.
(Reporter)

Comment 1

18 years ago
Created attachment 17821 [details] [diff] [review]
Propogate exit codes in wrapper scripts

Comment 2

18 years ago
what file are you patching exactly? 
(Reporter)

Comment 3

18 years ago
The patch applies to the scripts 'mozilla' and 'run-mozilla.sh' that are in the
distributed tarball.  Since I don't have a checked out tree, I don't know where
they are in the build tree.  

Also, the names of the files aren't clear in the patch.  Here's the relevant
part of the patch:

  --- mozilla~    Fri Jun 16 19:54:07 2000
  +++ mozilla     Mon Oct 23 17:42:08 2000
[snip]
  --- run-mozilla.sh~     Thu Sep 14 15:58:56 2000
  +++ run-mozilla.sh      Mon Oct 23 17:43:52 2000

If you want me to, I can check out a copy of the mozilla development tree and
create a new patch (but I would prefer not to, it takes up too much space ;-).

Comment 4

18 years ago
Patch looks as though it should work (untested). Marking New.

Reassigning component to XP-Apps: Cmd-line Features.
Assignee: asa → don
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Apps: Cmd-line Features
Ever confirmed: true
QA Contact: doronr → sairuh

Updated

18 years ago
Assignee: don → cls
Component: XP Apps: Cmd-line Features → Build Config
QA Contact: sairuh → granrose

Comment 5

18 years ago
buildconfig

cc: granrose and leaf, our build people, and ramiro, who seems to be the owener
of run-mozilla.sh

Comment 6

18 years ago
cc cls, as per granrose.
(Assignee)

Comment 7

18 years ago
Patch has been checked in.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 8

18 years ago
verified fixed.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.