When editing contributions Paypal id is flagged as - 'Account is restricted' wrongly and contribution amount does not get changed

RESOLVED FIXED in 5.11.5

Status

defect
RESOLVED FIXED
9 years ago
3 years ago

People

(Reporter: contact, Assigned: osunick)

Tracking

unspecified
5.11.5

Details

(Whiteboard: [qa-], )

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6 (.NET CLR 3.5.30729)
Build Identifier: 

When I try to edit the contribution amount my existing saved Paypal id is flagged as 'Account is restricted' and the amount change does not reflect when page is reloaded. The paypal account is an verified Premier account and has no restictions what-so-ever .

Screenshot - 

Reproducible: Always

Steps to Reproduce:
1. Login to 'Add-on Developer Hub'
2. Goto 'Manage Contributions' page
3. Change existing Paypal amount

Actual Results:  
Paypal id is flagged as 'Account is restricted' and the amount change does not reflect when page is reloaded.

Expected Results:  
No red flag and updation of new contribution amount.
Reporter

Comment 1

9 years ago
Oops, forgot to add the screenshot link - http://imgur.com/N2jj9.jpg

Comment 2

9 years ago
I'm having the same issue as Deepesh Agarwal above.  When I try to add my PayPal email address to the contribution area of my extension, it errors in red text with the message "Account is restricted" -- even though my PayPal account has been confirmed to not be restricted.

Screen shot of trying to add PayPal email address to contribution section of extension: http://imgur.com/QgwVj.jpg

Screen shot of PayPal account showing good standing: http://imgur.com/IUhNe.jpg
(I called PayPal to verify, and was told there WOULD be a message on this screen if I was restricted or limited in any way.  I was told my account is not limited in any way.)

Reproducible: Always

Steps to Reproduce:
1. Login to "Add-on Developer Hub"
2. Select extension you wish to add a contribution form to in the "My Addons" area.
3. Click "Manage Contributions" at the bottom of the available actions list.
4. Click "Start asking for contributions" button.
5. Enter PayPal email address or merchant ID in the provided field, and also fill out suggested amount and answer "where to ask" question.
6. Save the form.

Actual Results:  
PayPal email address is flagged as 'Account is restricted' and none of the form values are saved.

Expected Results:  
The addition of contribution information to the extension.

Comment 3

9 years ago
Oh, I'm using Mozilla Firefox 4.0 beta 1 to attempt this.
Weird.  It looks like we're looking for Paypal to return the string "Success" in their response because they don't use HTTP status codes correctly.  I wonder if they changed that.  Wouldn't be the first time. :-/

controllers/components/paypal.php:77
(In reply to comment #4)
> Weird.  It looks like we're looking for Paypal to return the string "Success"
> in their response because they don't use HTTP status codes correctly.  I wonder
> if they changed that.  Wouldn't be the first time. :-/

The error message comes directly from the paypal response so I don't think there's anything faulty in our handling.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Target Milestone: --- → 5.11.4

Comment 6

9 years ago
(In reply to comment #5)
> (In reply to comment #4)
> > Weird.  It looks like we're looking for Paypal to return the string "Success"
> > in their response because they don't use HTTP status codes correctly.  I wonder
> > if they changed that.  Wouldn't be the first time. :-/
> 
> The error message comes directly from the paypal response so I don't think
> there's anything faulty in our handling.

Perhaps its Mozilla's API account that is currently restricted, thus affecting all PayPal accounts?  Just wonderin.
@Jay, I think that's the case.  I'm checking it out.
(In reply to comment #7)
> @Jay, I think that's the case.  I'm checking it out.

This is correct, the Mozilla account has been restricted.  We're working on it.
Assignee: nobody → nnguyen
Whiteboard: [qa-]

Comment 9

9 years ago
Fixed.  I just successfully added my PayPal email address to the extension and updated my contribution information.  Thanks for the help!
That's weird.  The account is still locked - we're waiting on Paypal to fix it.

Comment 11

9 years ago
Interesting. It totally just worked.  Screen shot below:

http://imgur.com/O8eRi.png

Comment 12

9 years ago
Oh, as a side note, you may have noticed the email address was different from the "not working" one and the "working" one.  They are both on the same PayPal account... I just updated to the original one that didn't work, and it worked flawlessly (just to verify).
Target Milestone: 5.11.4 → 5.11.5
This should be fixed.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.