DocumentType.entities & DocumentType.notations are returning NULL

VERIFIED INVALID

Status

()

Core
DOM
P3
normal
VERIFIED INVALID
18 years ago
17 years ago

People

(Reporter: Jan Carpenter, Assigned: jst)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Overview Description: 
DocumentType.entities & DocumentType.notations are returning NULL

Steps to Reproduce: 
- see attached testcase

Actual Results: 
document.doctype.entities = null
document.doctype.notations = null
document.doctype.name = HTML

Expected Results: 
document.doctype.entities = HTML
document.doctype.notations = HTML
document.doctype.name = HTML

Build Date & Platform Bug Found: 
2000-10-23-09-MN6 : win32 

Additional Builds and Platforms Tested On: 
2000-10-23-13-MN6 : linux
2000-10-23-18-MN6 : mac
(Reporter)

Comment 1

18 years ago
Created attachment 17830 [details]
attaching testcase
(Assignee)

Comment 2

18 years ago
Huh? Why should doctype.notations or doctype.entities be 'HTML'? They should be
NamedNodeMaps that list the notations and entites defined in the DTD for the
document but since mozilla (and every other browser I've ever seen) never really
reads the DTD, they're null.

Closing as INVALID.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

18 years ago
marking verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.