Closed Bug 577468 Opened 11 years ago Closed 11 years ago

when using 2 caldav calenders under the same domain, lightning asumes the same username/password

Categories

(Calendar :: General, defect)

x86
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 247486

People

(Reporter: shaiay, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.99 Safari/533.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.4) Gecko/20100608 Lightning/1.0b2 Thunderbird/3.1

I use 2 different caldav calendars under google. one is my private calendar, and one is from google apps. The problem is that the URL for both goes to www.google.com:
https://www.google.com/calendar/dav/ [ Google Calendar ID ] /events
the difference is the Google Calendar ID.
Lightning however only asks for the username/password once, and tries to use it for both accounts, one of them invariably failing

Reproducible: Always

Steps to Reproduce:
1. get yourself 2 google accounts with calendar, and different passwords
2. define the two respective caldav remote calendars
3. you get only one password prompt from lightning
Actual Results:  
one pasword is prompted for / remembered for all accounts on the same server

Expected Results:  
a username/password should be assigned to each individual calendar

I expect this is because the username/password is assigned per server, and these calendars reside on the same server.
This however should be fixed since it cannot be assumed that different accounts reside on different servers
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 247486
You need to log in before you can comment on or make changes to this bug.