Thunderbird with Lightning crashes w/o errors in terminal before opening a window

RESOLVED DUPLICATE of bug 576319

Status

Calendar
General
--
critical
RESOLVED DUPLICATE of bug 576319
8 years ago
7 years ago

People

(Reporter: dgortze380, Unassigned)

Tracking

({crash})

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6 ( .NET CLR 3.5.30729)
Build Identifier: Lightning 1.0b2

On Scientific Linux 5.1
Thunderbird 3.1.0 and Lightning 1.0b2

Thunderbird works correctly. As soon as lightning is installed, you are prompted to restart Thunderbird, Thunderbird restarts correctly. After closing Thunderbird, the program consistently crashes when you try to run it. No error messages are output, it just fails to start.

Removing the users .thunderbird and .mozilla directories allows Thunderbird to start again (presumably because this disables the Lightning plug-in).

Reproduced on 2 machines by 2 users.

Thunderbird 3.0.5 with Lightning 1.0b1 does not exhibit this behavior

Reproducible: Always

Steps to Reproduce:
1. Install Thunderbird 3.1.0 on Scientific Linux 5.1 x86 with GNOME
2. Open and Close Thunderbird more than twice (to prove it starts with no issues)
3. Install Lightning 1.0b2 Extension
4. Restart Thunderbird to complete Installation (this will complete successfully)
5. Verify Lightning is installed and working, create test Event
6. Close Thunderbird
7. Try to start Thunderbird. This will fail, with no errors output to the terminal.
8. Repeat 7 a number of times to prove consistent crashes
9. Remove ~/.mozilla and ~/.thunderbird to disable Lightning Extension
10. Start Thunderbird (this will complete successfully)
11. Open and Close Thunderbird more than 2 times to prove it works w/o Lightning
Actual Results:  
Crash was reproduced.

Thunderbird fails to start with no errors output to the terminal after Lightning is installed.

Expected Results:  
Thunderbird should have started and displayed a window

Comment 1

8 years ago
Probably identical to Bug 575048 and Bug 576319.

Comment 2

7 years ago
dupe to Bug 576319?
Bug 575048 was closed
Keywords: crash
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 576319
You need to log in before you can comment on or make changes to this bug.