If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Release Notes for Camino 2.1a1

RESOLVED FIXED

Status

Camino Graveyard
General
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Smokey Ardisson (offline for a while; not following bugs - do not email), Assigned: Smokey Ardisson (offline for a while; not following bugs - do not email))

Tracking

Details

(URL)

Attachments

(1 attachment)

Coming soon-ish…
Assignee: nobody → alqahira
Status: NEW → ASSIGNED
Flags: camino2.1a1+
Created attachment 503730 [details]
very rough first cut at relnotes

Here's the first stab at this; it's rougher than usual, but I'm out of ideas for rewriting all of the awkward sentences ;)
Attachment #503730 - Flags: superreview?(stuart.morgan+bugzilla)
I just remembered(!) that the “Enable Java” checkbox probably needs to be relnoted as a Known Issue:

* The “Enable Java” preference in the Web Features preference pane is currently non-functional, and Java will always be enabled regardless of the state of the checkbox.

I have it situated right at the end of the new issues, just before the carry-over, in the #4 spot.
Blocks: 623439

Comment 3

7 years ago
We should probably aim for getting the Java patch landed for a1 now that it's done, so we don't have to relnote it, but that language is good if we need it.

If we do land it, should we say that Java is now disabled by default in another part of the notes?

Comment 4

7 years ago
Comment on attachment 503730 [details]
very rough first cut at relnotes

Do we really want to relnote Mork-death? I can't imagine users caring.

Suggested changes, none of which I'm attached to if you disagree:
- s/Downloaded files/Completed downloads for files/
- Remove "instead of text highlight colors"
- Change the Tabs heading to AppleScript, since the audience for that is more specialized
- "can again be reassigned" is awkward. s/again/now/?
- Should we trim some of the minor stuff in the UI section? Seems a bit long.
Attachment #503730 - Flags: superreview?(stuart.morgan+bugzilla) → superreview+
(In reply to comment #3)
> We should probably aim for getting the Java patch landed for a1 now that it's
> done, so we don't have to relnote it, but that language is good if we need it.

So we now have Java and FAYT with patches, and we could spin the plug-in finding over into a "Web Page Interaction" relnote rather than a Known Issue now that we have a fix (and, honestly, probably the fix) for bug 626142; that's 3 of the 4 Known Issues we added.

Should we take all of them?  If so, can we get pink to sr things (early) this week?

As it stands right now, if pink got the missing history patch Monday, we could spin Monday night and probably release a1 on Thursday.

Anything more, and a1 moves to next week (and I'm a little wary of landing the big Java change and spinning immediately thereafter, without at least one day for it to shake out in the nightlies). 
 
> If we do land it, should we say that Java is now disabled by default in another
> part of the notes?

Yes (Web Page Interaction).

(In reply to comment #4)
> Do we really want to relnote Mork-death? I can't imagine users caring.

They probably don't care, although it was a major underlying change that would be nice to mention if there were a non-awkward way of doing so.  (E.g., if you back up history.dat every night, your history backup's going to be useless without changes.)

> Suggested changes, none of which I'm attached to if you disagree:
> - s/Downloaded files/Completed downloads for files/

Sounds good.

> - Remove "instead of text highlight colors"

Debated over that when writing; gone.

> - Change the Tabs heading to AppleScript, since the audience for that is more
> specialized

I'd rather stick to our standard set of headings, so I'll just move that note up to General and remove Tabs for this release.

> - "can again be reassigned" is awkward. s/again/now/?

OK.

> - Should we trim some of the minor stuff in the UI section? Seems a bit long.

It's usually long (at least for the first alpha), since inevitably we spend a lot of time fixing little UI issues that bothered us after string freeze.

However, I collapsed the three toolbar/menu validation items into 

* Many additional toolbar buttons and menu items are now only enabled when appropriate.

and culled the item about Esc in the feed first-run warning, which is the one people are least likely to ever see or care about :P

Proposals for new notes:

=Web Page Interaction=
* Java is now disabled by default; it can be re-enabled in the Web Features preference pane.
* The new “camino.disable_plugin_names” hidden preference allows disabling arbitrary plug-ins.
* Placeholders for missing, disabled, and blocked plug-ins now appear as inline grey boxes in web pages.

(Happy with the first two, but the third one needs help.)

Comment 6

7 years ago
I go back and forth. Getting a1 out ASAP would be nice, but it also feels a bit odd to ship a version that calls out regressions we already have patches for.

How long do we thing Gecko string auditing will take? Could we do b1 (with string freeze), say, two weeks after a1? If so, then lets go a1 now.
And:

==UI==
* The lock and feed icons, if present, now appear in their own section of the location bar.

==Preferences==
* Switched the order of the tabs in the Appearance preference pane.
* Removed the checkbox for “Always use my page and link colors” from the “Colors & Links” tab of the Appearance preference pane.


In summary (all of the changes/proposed changes made since comment 4 was made): http://wiki.caminobrowser.org/index.php?title=Releases%3A2.1a1%3ANotes&action=historysubmit&diff=11641&oldid=11636

Comment 8

7 years ago
All looks good, except it should be disabled_plugin_names, not disable_plugin_names
(In reply to comment #8)
> All looks good, except it should be disabled_plugin_names, not
> disable_plugin_names

Fixed.

And push, with installer Makefile kicking, as http://hg.mozilla.org/camino/rev/ee145ba36286
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
…and http://hg.mozilla.org/camino/rev/3d2802db1cc3 for philippe's typo-catch.
You need to log in before you can comment on or make changes to this bug.