"Documentation" link in header should open in new tab

RESOLVED FIXED

Status

Mozilla Labs Graveyard
FlightDeck
--
major
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: KWierso, Assigned: dietrich)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; en-US; rv:2.0b2pre) Gecko/20100707 Firefox/3.7a5pre RTSE/1.2.0.20100320
Build Identifier: 

If you're in the Addons Builder, clicking the Documentation link up in the site header will open it in the current tab. I'd argue that it should open in either a new tab, new window, or in a sidebar-type thing. At least if you're in the Edit or View Source page for an addon.

My scenario I've hit many times: I'm working on my extension in the Addons Builder, and I try to open the documentation page to look up one of the modules, only to be moved from my extension to the documentation in the current tab.

It would flow much better for me if it were to open outside of the current tab, so I can easily go back and forth from the documentation and my extension's code, without having to remember to middle-click the link.

Reproducible: Always

Actual Results:  
Documentation opens in current tab.

Expected Results:  
Documentation opens outside of the current tab.
(Assignee)

Comment 1

8 years ago
Confirming, and upgrading to "major" - because Builder doesn't auto-save, or warn when leaving the page with unsaved changes (bug 577735), this bug can cause data-loss.
Severity: enhancement → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
(Assignee)

Comment 2

8 years ago
Created attachment 456626 [details] [diff] [review]
v1 - target=new
Assignee: nobody → dietrich
Attachment #456626 - Flags: review?(zaloon)
could you please give me the git(hub) link?
(Reporter)

Comment 4

7 years ago
This seems to be fixed (at least) on the staged version of the Builder: http://flightdeck.zalewa.info/
Indeed!
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Attachment #456626 - Flags: review?(zaloon)

Updated

7 years ago
Component: FlightDeck → FlightDeck
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.