Clicking on a URL in the address card pane loads the web page in the address book window

VERIFIED FIXED

Status

SeaMonkey
MailNews: Address Book & Contacts
P3
normal
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Simon Fraser, Assigned: Jessica Blanco)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 5 obsolete attachments)

(Reporter)

Description

17 years ago
Make a new address book card, enter the person's details, and enter a URL. Commit 
the changes.

Now click on that new card so that it loads in the address window. Click on the 
URL. Note that the URL loads in the address book window, replacing all the chrome 
in that window. The menus (on Mac) also become totally messed up.

The only way out is to close the address book window.
(Reporter)

Comment 1

17 years ago
Seems pretty serious; nominate for rtm.
Keywords: rtm

Comment 2

17 years ago
We don't get the menus problem on Windows. Instead, all of the chrome for the AB
disappears.

I agree that this is lame, but I don't think this feature is high enough
priority to warrant fixing for rtm.

marking [rtm-]
OS: Mac System 8.5 → All
Whiteboard: [rtm-]

Updated

17 years ago
QA Contact: esther → suresh

Updated

17 years ago
QA Contact: suresh → pmock

Comment 3

17 years ago
Couldn't you just add a target="_blank" attribute to both the cvHomeWebPage and
cvWorkWebPage elements ??  That will launch a new browser window.

Comment 4

17 years ago
reassigning to chuang
Assignee: putterman → chuang

Comment 5

17 years ago
Qa-assign-to fenella
QA Contact: pmock → fenella

Comment 6

17 years ago
Linux (2001-03-13-08 mtrunk)
Win32 (2001-03-13-10 mtrunk)
Mac (2001-03-12-11 mtrunk)
Re-test this bug and find no problem in these builds.
Mark it worksforme
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 7

17 years ago
.
Status: RESOLVED → VERIFIED

Comment 8

16 years ago
Unsure why this bug was marked as verified since this problem still exists in
the Mozilla 0.9.3 baseline.  Clicking on the web page link replaces the address
book window with the website with NO controls.

This problem can be fixed by adding a target="_blank" attribute to both the
cvHomeWebPage and cvWorkWebPage.

Please reopen this bug.
(Reporter)

Comment 9

16 years ago
This is still happening.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 10

16 years ago
To default owner.
Status: REOPENED → NEW
QA Contact: fenella → nbaca
(Reporter)

Comment 11

16 years ago
Candice is no longer here.
Assignee: chuang → putterman

Comment 12

16 years ago
reassigning to racham
Assignee: putterman → racham

Comment 13

16 years ago
*** Bug 72212 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
*** Bug 97296 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Keywords: nsbeta1
Whiteboard: [rtm-]
(Assignee)

Comment 15

16 years ago
Created attachment 53624 [details] [diff] [review]
Modified mailnews\addrbook\resources\content\abCardViewOverlay.xul
(Assignee)

Comment 16

16 years ago
With above changes, when user clicks on a url in the Address Book Card 
Viewer window, a new browser window will open with that url.
(Reporter)

Comment 17

16 years ago
Do we always want a new window, or should it use the frontmost existing browser 
window if one exists?

Comment 18

16 years ago
Jessica, thanks for tackling this one also.  cc'ing sspitzer.  I think it should
use the frontmost browser window like we do for clicking on a link in a mail
window.  Jennifer, any opinion?

Comment 19

16 years ago
The behavior should be the same as when clicking on a link in the mail window.
(Assignee)

Comment 20

16 years ago
Created attachment 54233 [details] [diff] [review]
modified abCardViewOverlay.js/xul to where clicking on url will open link in existing browser
(Assignee)

Comment 21

16 years ago
Above patch includes fixes for bugs 92168 and 72213. User can now view 
email addresses and urls as links, click on an email address and a 
compose message window will come up, and click on a url and the page 
will come up in top browser window or open new browser window if one 
is not already open.

Comment 22

16 years ago
r=bhuvan.

Updated

16 years ago
Keywords: nsbeta1 → nsbeta1+

Updated

16 years ago
Attachment #54233 - Flags: review+
Created attachment 55422 [details] [diff] [review]
updated fix
Created attachment 55424 [details] [diff] [review]
updated patch
here's an updated patch, based on jessica's original patch.

one problem with the original patch was that when mousing over the web page 
links, the mouse would not change (indicating it was a link).

so, I copied her trick putting a box around the <a> node.

but if you use href, we open in the ab window.

if we do target="new", we'll always open in a new window, not the top most.

I use onclick="return openLink()" and always return false from openLink() so 
that we don't do the href.
credit to jessica, for the original patch.
Assignee: racham → jblanco
other difference between the last patch and the original patch is that if the 
html links are not visible, I don't do the , if the html links are not visible, 
I don't do the setAttribute().
Created attachment 55426 [details] [diff] [review]
more cleanup of the patch, new function, HandleLink() does all the work.
Created attachment 55427 [details] [diff] [review]
remove unused variables.
Attachment #53624 - Attachment is obsolete: true
Attachment #55422 - Attachment is obsolete: true
Attachment #54233 - Attachment is obsolete: true
Attachment #55426 - Attachment is obsolete: true
Attachment #55424 - Attachment is obsolete: true
fixed.

thanks for the patch, jessica.
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → FIXED

Comment 31

16 years ago
Trunk build 2001-11-13-03: WinMe
Trunk build 2001-11-09: Linux RH 7.1, Mac 9.1
Verified Fixed, it now opens a browser window displaying the page.
Status: RESOLVED → VERIFIED
whoops, the home page link is not blue, like the other links.

I've logged another bug for that, fix in hand.
see http://bugzilla.mozilla.org/show_bug.cgi?id=112786
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.