If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Items in xul textfield context menus need to enable/disable at proper times

VERIFIED FIXED

Status

()

Core
Editor
P3
normal
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: Blake Ross, Assigned: Blake Ross)

Tracking

({helpwanted})

Trunk
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Assignee)

Description

17 years ago
Undo needs to be enabled when there's nothing to be undone in the new xul 
textfield context menus (trunk only).
(Assignee)

Comment 1

17 years ago
Actually, all of the items (except Select All) need to be enabled/disabled at 
the right moments.
Summary: Undo is always enabled in xul textfield context menus → Items in xul textfield context menus need to enable/disable at proper times

Comment 2

17 years ago
->future
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 3

17 years ago
->untargetted. cc pink & saari.  who should get this?
Target Milestone: Future → ---
MHO is that this is ender's bug, not a toolkit bug, as it deals with content of
the menus, not the menus. right?

all that's needed is an oncreate handler like in navigator.

Comment 5

17 years ago
Okay, didn't know if there was one and it was just not working. Thanks! ->editor
Assignee: trudelle → beppe
Status: ASSIGNED → NEW
Component: XP Toolkit/Widgets → Editor
QA Contact: jrgm → sujay
(Assignee)

Comment 6

17 years ago
oh, I'll do it you big baby ;) (er, pink that is).
Assignee: beppe → blakeross
(Assignee)

Comment 7

17 years ago
*** Bug 64200 has been marked as a duplicate of this bug. ***
OS: Windows 98 → All
Hardware: PC → All

Comment 8

17 years ago
if i ever get focused i might look at this again.
Keywords: helpwanted
(Assignee)

Comment 9

17 years ago
Created attachment 23226 [details] [diff] [review]
[patch] disable when necessary...

Comment 10

17 years ago
what about redo and delete commands?  Should those be handled too?
(Assignee)

Comment 11

17 years ago
Ack...nice catch.  Apparently whoever implemented these textfields originally 
mistakenly used cmd_cut instead of cmd_delete when getting the controller, and 
I just looked down the list when writing the array.  I didn't catch this when 
testing because Delete and Cut are enabled/disabled at the same time.

Note also that for now we don't try to enable/disable Select All, because it 
never disables (there's another bug on disabling Select All when all the text 
is selected).

We have a separate bug on whether or not to add Redo.

brade, wanna review this?
Status: NEW → ASSIGNED
(Assignee)

Comment 12

17 years ago
Created attachment 23278 [details] [diff] [review]
[patch] fix delete

Comment 13

17 years ago
sidenote:  select all should also be disabled if there is no text
(Assignee)

Comment 14

17 years ago
Created attachment 23299 [details] [diff] [review]
[patch] simplified
(Assignee)

Comment 15

17 years ago
Created attachment 23300 [details] [diff] [review]
[patch] and now, the whole patch...(i'm an idiot)

Comment 16

17 years ago
while you're making major changes, could you aim for 80-82 columns?

Comment 17

17 years ago
r=timeless given assurance that the committed version addresses my concern.
(Assignee)

Comment 18

17 years ago
cc'ing alec for sr

Comment 19

17 years ago
looks good blake... thanks for cleaning it up
sr=alecf
(Assignee)

Comment 20

17 years ago
checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 21

17 years ago
*** Bug 63693 has been marked as a duplicate of this bug. ***

Comment 22

17 years ago
verified in 2/6 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.