If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

popup.position after_start ignored on toolbar button menus

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: realRaven, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2012-03-01])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; sr-RS; rv:1.9.2.4) Gecko/20100608 Lightning/1.0b2 Thunderbird/3.1

popup menus on my extension's toolbar buttons do not popup where expected (bottom left of the button, instead they show at cursor position) although in DOM Inspector they show as position=start. 

Same works as expected in Thunderbird 2. 

Reproducible: Always

Steps to Reproduce:
1. Install QuickFolders https://addons.mozilla.org/en-US/firefox/addon/3254
2. drag a folder to the new toolbar. This will be styled as a "Tab" (it is a button).
3. right-click on the new Tab. 
Actual Results:  
A popup menu will show up on Cursor Position. 

Expected Results:  
The popup menu should show up below the button, left-aligned (after_start). In DOM Inspector, the relevant menupopup.position reads as after_start. The expected behavior works in TB2, which is indicative of a change in the Gecko Code base.

Since it is a minor bug I would be grateful for a workaround as well.
blake ideas ?
Reporter, 

do you still see this problem when using a current version of thunderbird? 

And if you do not, please close bug report by changing resolution to worksforme
Whiteboard: [closeme 2012-03-01]
(Reporter)

Comment 3

6 years ago
Ok, at the moment I am using a workaround.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.