nsBookmarksService never calls nsIRDFService::UnregisterDataSource() [@ RDFServiceImpl::GetDataSource]

VERIFIED FIXED

Status

SeaMonkey
Bookmarks & History
P3
normal
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Chris Waterson, Assigned: Chris Waterson)

Tracking

({topcrash})

Trunk
topcrash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
I'm guessing that this may be the cause for the topcrash in RDFServiceImpl, see

http://www.mozilla.org/projects/seamonkey/reports/ns6analysis.html
(Assignee)

Comment 1

17 years ago
taking bug unto myself
Assignee: ben → waterson
(Assignee)

Updated

17 years ago
Keywords: topcrash
(Assignee)

Comment 2

17 years ago
Created attachment 17851 [details] [diff] [review]
be sure to unregister bookmarks datasource in dtor

Comment 3

17 years ago
Yeah, baby;  that's a good one.  r=rjc
(Assignee)

Comment 4

17 years ago
fix checked in
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

17 years ago
Some crash data still reported after 10-24; see also bug 58252.
Summary: nsBookmarksService never calls nsIRDFService::UnregisterDataSource() → nsBookmarksService never calls nsIRDFService::UnregisterDataSource() [@ RDFServiceImpl::GetDataSource]
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
Crash Signature: [@ RDFServiceImpl::GetDataSource]
You need to log in before you can comment on or make changes to this bug.