d&d bookmarks will crash if i have previously scrolled in sidebar

VERIFIED DUPLICATE of bug 55909

Status

SeaMonkey
Sidebar
P3
critical
VERIFIED DUPLICATE of bug 55909
17 years ago
13 years ago

People

(Reporter: R.K.Aa., Assigned: matt)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Been seeing this for some days.
It is also in the trunk, 2000102321 SEA Linux.

If i first scroll in sidebar and then d&d a bookmark, moz crashes.
It i only d&d the bookmark, and raise it ABOVE the first bookmark (or folder)
X will freeze and has to be killed. (ctrl+alt+backspace)

As the freeze of X occures, the cursor icon turns into an angle with a + sign on.
This jams the whole GUI.

Must have crashed 50 times now, over the past 4 days, but talkback doesn't work
on Linux :/

This bug resembles 55909 where forcing d&d scroll in bookmark manager will
trigger a crash. I crash all the time in both sidebar and bookmark manager on
linux as well, but 55909 is seemingly considered a Windows bug.
And worse: It's futured!

When a user has run mozilla for a week or so, she has likely collected enough
bookmarks to trigger this bug very very often. In all practical terms it makes
managing bookmarks close to impossible. Bugs like these should not be futured,
they are critical to basic functionality.
I'm able to reproduce this on linux easily.  (just drag and drop a url from the
location bar into the "Manage Bookmarks" window.)

cc'ing blizzard, master of linux d&d.

I haven't tried win or mac yet.
adding me to the cc list.

Comment 3

17 years ago
qa:claudius
QA Contact: shrir → claudius
(Reporter)

Comment 4

17 years ago
Correcting timespan:
This bug became annoyingly obvious to me first in trunk evening-build the 20'th.

Updated

17 years ago
Keywords: crash

Comment 5

17 years ago
adding crash keyword.  

claudius: do you see this on other platforms?
(Reporter)

Comment 6

17 years ago
Sinced bug 55909 was later set as OS: All,
resolving this one as a dup.

*** This bug has been marked as a duplicate of 55909 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
marking verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.