bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

long delays between clicking Save and when Save dialog box appears

RESOLVED WORKSFORME

Status

Camino Graveyard
General
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: krag, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en; rv:1.9.0.19) Gecko/2010051911 Camino/2.0.3 (like Firefox/3.0.19)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en; rv:1.9.0.19) Gecko/2010051911 Camino/2.0.3 (like Firefox/3.0.19)

long delays between clicking Save and when Save dialog box appears, it can take a minute from the time I CMD-S or File Save and a Save dialog box appears... when I make a New window it's immediate, but not Save. This does NOT occur with Firefox or Safari.


Reproducible: Always

Steps to Reproduce:
1. CMD-S
2. Wait, wait, wait (up to a couple minutes)
3. Save dialog box appears
(Reporter)

Comment 1

8 years ago
I've noticed it has to do with how big the web page is (how much info).. for example one page has 3 tables with multiple rows, columns and is 49Kb takes 30 seconds for the Save dialog box, whereas this page post_bug.cgi which is 12Kb takes 2 seconds from Cmd-S to when the dialog box appears.

Comment 2

8 years ago
Does it make any difference how many other windows/tabs you have open at the time?

Does this also happen in the latest nightly builds?
(Reporter)

Comment 3

8 years ago
Does it make any difference how many other windows/tabs you have open at the
time?
NO. For the slower pages it takes about the same amount of time from CMD-S to dialog box, as it does to View Page Source to show the page source. It may be the websites?

Does this also happen in the latest nightly builds?

I downloaded Version 2.0.3 (1.9.0.19 2010051911)
Checking updates now it says "You're up-to-date"

Comment 4

8 years ago
No, for a nightly build, you want this:

http://caminobrowser.org/download/releases/nightly/

The releases won't automatically update to nightly builds, only other release builds.
(Reporter)

Comment 5

8 years ago
I tested the same page with Firefox and Safari and there is no noticeable lag between CMD-S and the dialog box or View Source and viewing source.
(Reporter)

Comment 6

8 years ago
(In reply to comment #4)
> No, for a nightly build, you want this:
> 
> http://caminobrowser.org/download/releases/nightly/
> 
> The releases won't automatically update to nightly builds, only other release
> builds.

I'll try the build and let you know. Thanks.
This is probably related to how we fetch the filename and other info (the so-called "busted sniffing code"), as well as performance of the server and network link.  When Firefox added its sniffing code, it either got backed out or they changed the timeout before falling back to "Untitled" (I can't remember now) because there are too many non-responsive servers on the internet.
(Reporter)

Comment 8

8 years ago
(In reply to comment #6)
> (In reply to comment #4)
> > No, for a nightly build, you want this:
> > 
> > http://caminobrowser.org/download/releases/nightly/
> > 
> > The releases won't automatically update to nightly builds, only other release
> > builds.
> 
> I'll try the build and let you know. Thanks.

no difference
(Reporter)

Comment 9

8 years ago
I prefer using Camino because Safari crashes a lot on mail.yahoo.com and has flash issues also Firefox keeps getting errors for Flash (you need v 9 or newer, when I have v 10. installed).

Thanks for Camino!
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Comment 10

8 years ago
Does WORKSFORME mean that you are no longer experiencing the problem?

Comment 11

7 years ago
(In reply to Smokey Ardisson (back-ish; no bugmail - do not email) from comment #7)

> This is probably related to how we fetch the filename and other info (the
> so-called "busted sniffing code"), as well as performance of the server and
> network link.  When Firefox added its sniffing code, it either got backed
> out or they changed the timeout before falling back to "Untitled" (I can't
> remember now) because there are too many non-responsive servers on the
> internet.

Camino fetches again this info ? Instead of using the info he has already fetched to display the page ?
You need to log in before you can comment on or make changes to this bug.