Compilation on an alpha-processor (Linux RedHat 6.2)

VERIFIED WORKSFORME

Status

SeaMonkey
Build Config
P3
blocker
VERIFIED WORKSFORME
17 years ago
13 years ago

People

(Reporter: bertrand, Assigned: cls)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Good morning,

	Since a few week, I cannot compile mozilla from
sources. g++ returns an error with the default configuration at
c++ -o nsBulletinBoardLayout.o... The last lines of the output of
the make are :

../../../../dist/include/nsISelection.h:24: redefinition of `class nsISelection'
../../../base/public/nsISelection.h:71: previous definition here
../../../../dist/include/nsISelection.h:83: conflicting types for `void
__vt_12nsISelection'
../../../base/public/nsISelection.h:71: previous declaration as `int (* const
nsISelection::__vt_12nsISelection[8])(...)'
../../../../dist/include/nsISelection.h:83: confused by earlier errors, bailing
out
make[4]: *** [nsBulletinBoardLayout.o] Error 1
make[4]: Leaving directory
`/export/perceval/pelles/bertrand/mozilla-en-cours/mozilla/layout/xul/base/src'
make[3]: *** [install] Error 2
make[3]: Leaving directory
`/export/perceval/pelles/bertrand/mozilla-en-cours/mozilla/layout/xul/base'
make[2]: *** [install] Error 2
make[2]: Leaving directory
`/export/perceval/pelles/bertrand/mozilla-en-cours/mozilla/layout/xul'
make[1]: *** [install] Error 2
make[1]: Leaving directory
`/export/perceval/pelles/bertrand/mozilla-en-cours/mozilla/layout'
make: *** [install] Error 2

	I think that it is a C++ problem, but I don't know this language.

	Regards,

	JKB

Updated

17 years ago
QA Contact: gemal → gbush

Comment 1

17 years ago
Have you taken a look at the build pages yet?  
If not, it is located here:
  http://mozilla.org/build/unix.html

Also, make sure tinderbox is showing green for the platform that you're trying 
to build  on.  This page contains that info.
  http://tinderbox.mozilla.org/showbuilds.cgi?tree=SeaMonkey

(ps. this is not an installer issue)
Assignee: ssu → cls
Component: Installer → Build Config
QA Contact: gbush → granrose
(Assignee)

Comment 2

17 years ago
bertrand, which versions of gcc, binutils & glibc are you using?

msw, any ideas?

Comment 3

17 years ago
my builds as of Oct 17 with my gcc 2.96 snapshot work, egcs 1.1.2 should work as
well.

Comment 4

17 years ago
verified that a fresh pull works on 2.96, I'll check agains egcs 1.1.2 next.
msw@redhat.com - is this still working for you?

Gerv

Comment 6

17 years ago
yes, this seems to be working fine on egcs 1.1.2 and gcc 2.96 (cvs)

Comment 7

17 years ago
Marking as WORKSFORME as per users comments. Reopen if you continue to see this
problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 8

17 years ago
verified worksforme.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.