Closed Bug 577868 Opened 14 years ago Closed 3 years ago

Windows 7 Taskbar: 'Close All Windows' should behave like Firefox -> Exit

Categories

(Firefox :: General, defect)

x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: ronin.achilles, Unassigned)

References

Details

(Keywords: dataloss)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; en-US; rv:2.0b2pre) Gecko/20100710 Minefield/4.0b2pre
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; en-US; rv:2.0b2pre) Gecko/20100710 Minefield/4.0b2pre

In its current implementation 'Close All Windows' from Windows 7 Taskbar closes the windows in certain order. It does not end the 'session'. As a result when Firefox is launched again, only the Last Window in the order is restored, instead of All the windows.

This is with 'Show My Windows and Tabs from Last Time' option enabled.

Reproducible: Always

Steps to Reproduce:
1. Launch Firefox
2. Open 3 Windows
3. Open a few Tabs in Each Window
4. Right Click Windows 7 Taskbar Icon and select 'Close All Windows'
5. Launch Firefox Again

Actual Results:  
One Window is Opened

Expected Results:  
All Windows should be restored.
Blocks: win7support
I think this should be marked WORKSFORME since after the removal of the "Save & Quit" dialogue it now functions identically to Exit AFAICT.
Version: unspecified → 4.0 Branch
No save and Quit Dialog is present in FF5 and I can still reproduce this issue. 
Marking as NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: 4.0 Branch → Trunk
Stumbled into this today on Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:14.0) Gecko/20120412 Firefox/14.0a1 ID:20120412030726 and lost two thirds of a major session as only the first window was restored on "Restore previous session".
Keywords: dataloss
Firefox 24
when using the application bar menu to 'close all windows' the program restores all it's windows to the desktop then crashes

second attempt:
restored to desktop
closed some of the windows
crashed.

when i re-opened Firefox, it loaded a session-restore page. - did not happen the first time.

when using the orange button, to 'Exit' it works normally.
On Fx27, using a new profile and multiple windows, each with multiple tabs, I see both Windows prompt "You are about to close {n} tabs.  Are you sure...".  If you answer "Close tabs" on both, only one of the windows (the last one you confirmed) is restored.

If I ask Firefox not to warn me when I'm closing multiple tabs, it works as expected.

(In reply to mjfulcher58 from comment #5)
> crashed.

I can't reproduce a crash.
Severity: normal → critical
Works for me on Windows 7 and Firefox 40.0.3

Following the reporter's steps I am able to confirm that the issues doesn't happen anymore on Windows 7 on any of the current versions of Firefox Nightly 87.0a1 (2021-02-22), beta 86.0 and release 85.0.2. Each window (with respective tabs) are re-opened upon relaunching Firefox (restore previous session is ticked).

Closing this issue as Resolved > Worksforme.
Feel free to re-open or file a new bug if this issue reoccurs again.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: