mark DEBUG only variables as ifdef DEBUG in editor

RESOLVED DUPLICATE of bug 605177

Status

()

Core
Embedding: APIs
RESOLVED DUPLICATE of bug 605177
8 years ago
8 years ago

People

(Reporter: timeless, Assigned: timeless)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

2.10 KB, patch
timeless
: review+
Details | Diff | Splinter Review
(Assignee)

Description

8 years ago
this is part of a crusade to get rid of compilation warnings
(Assignee)

Comment 1

8 years ago
Created attachment 456734 [details] [diff] [review]
patch
Assignee: nobody → timeless
Status: NEW → ASSIGNED
Attachment #456734 - Flags: review?(neil)

Comment 2

8 years ago
Comment on attachment 456734 [details] [diff] [review]
patch

Or NS_DEBUG_ONLY(nsresult rv =) or whatever the core review ends up with ;-)
Attachment #456734 - Flags: review?(neil) → review+
(Assignee)

Comment 3

8 years ago
Created attachment 463494 [details] [diff] [review]
using #ifdef DEBUG
Attachment #456734 - Attachment is obsolete: true
Attachment #463494 - Flags: review+
(Assignee)

Updated

8 years ago
Summary: use NS_DEBUG_ASSIGN for editor → mark DEBUG only variables as ifdef DEBUG in editor
(Assignee)

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 605177
You need to log in before you can comment on or make changes to this bug.