Profile on small Flash Memory Card runs out of space and renders Firefox virtually unrecoverable

RESOLVED DUPLICATE of bug 433445

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 433445
8 years ago
8 years ago

People

(Reporter: Art, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3) Gecko/20091020 Linux Mint/8 (Helena) Firefox/3.5.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3) Gecko/20091020 Linux Mint/8 (Helena) Firefox/3.5.3

Running Linux Mint 8 from a LOCKED 2 GB SD Flash Card (for secure web browsing) formatted vfat.  Running Firefox with a Profile (-profile option) I created on a 64 Meg CF Flash Card.  Over time, "Cache" folder climbed to over 20 megs, "urlclassifier.sqlite" to over 31.5 megs, and "places.sqlite" to over 2.2 megs.  This ran the media out of space and rendered Firefox virtually unuseable and unrecoverable.  I couldn't find any way to recover the original profile even though I had attempted to save it on a (windows XP) hard drive right after I had created it.

There has got to be some warning when disk space for the profile is low so that the Firefox profile doesn't suddenly (without warning) become unuseable.  Also, there has to be some way to clean out especially the "cache" folder and "urlclassifier.sqlite", which are by far the biggest files.



Reproducible: Always

Steps to Reproduce:
1. Run Linux from a Read Only system (LiveCD) - I use an SD flash card because it boots MUCH faster than a CD.
2. Create a profile on a small flash media/partition ... 16 megs is about the smallest that will accommodate a new profile.
3. Exercise the system until the media/partition fills and the profile is corrupted.
Actual Results:  
Corrupts the Profile, which can not be recovered.  The History window comes up totally blank and the History can not be erased.  Any attempts to delete the Profile and restore a copy results in "Firefox is already running, but is not responding.  To open a new window you must first close the existing Firefox process, or restart your system."  There does not appear to be any "Firefox process" in the System Monitor.  The Profile is now unusable.

Expected Results:  
1.  A sufficient warning should be generated when space for the non-default partition is low so that the profile is not crashed.
2.  After a warning is generated, (and perhaps a part of the warning!), there must be a safe means of resetting, clearing, or reducing the size of the contents of the "cache" folder and of the "urlclassifier.sqlite" file.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 433445
You need to log in before you can comment on or make changes to this bug.