Feedback button disappears when Sync is installed

RESOLVED DUPLICATE of bug 577349

Status

()

RESOLVED DUPLICATE of bug 577349
8 years ago
8 years ago

People

(Reporter: jzhang, Assigned: jono)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:2.0b1) Gecko/20100630 Firefox/4.0b1

Feedback button is not shown on the toolbar;
Feedback item is shown under the Menu->Tools;
When control click on the toolbar, the Feedback button is not shown in the customize your toolbar choices.
(Reporter)

Updated

8 years ago
Assignee: nobody → jdicarlo
(Assignee)

Comment 1

8 years ago
Note this is not the same issue as bug 577158 (Feedback button disappears if Tab Candy add-on installed).  In this bug, Tab Candy has not been installed.

Jinghua, didn't you say something about launching Firefox 4, then 3.6, then 4 again with the same profile?  I think I did something similar and now I don't have a Feedback button in Firefox 4 either.  We should try to repro this with a new profile and see if we can get an exact set of steps-to-reproduce.

Just in case it's relevant, here's the code in the Feedback extension that puts the button into the toolbar: http://hg.mozilla.org/labs/testpilot/file/a35ae871b895/extension/content/browser.js#l170
Jinghua, does a fresh profile work for you? See http://support.mozilla.com/en-US/kb/Managing+profiles

If that's the case please manually disable all extensions to check if one of those is causing the problem. You are testing on OS X, right?
(Reporter)

Comment 3

8 years ago
Thanks Henrik. 

After I disable BarTab 2.0, the Feedback button shows up again. 

(Bartab is my favorite add-on though.)
Thanks Jinghua. You should get in contact with the developer of BarTab and mention this problem.

I wonder if we could have a more robust way to make the button sticky so other add-ons aren't able to remove the button from the toolbar. Right now we are already aware of three different add-ons which are causing this situation.
Summary: Feedback button disappears → Feedback button disappears when BarTab is installed
Version: unspecified → Trunk
I believe this may be caused by bug 577349.
(Reporter)

Comment 6

8 years ago
(In reply to comment #5)
> I believe this may be caused by bug 577349.

While Bartab is enabled:
When I disable Sync 1.4, the Feedback button shows up again. 
When I enable Sync 1.4, the Feedback button disappears too.
Thanks Tracy and Jinghua for re-testing. So it's a dupe of bug 577349.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Summary: Feedback button disappears when BarTab is installed → Feedback button disappears when Sync is installed
Duplicate of bug: 577349
How exactly is this a dupe of bug 577349?
Jinghua mentioned in irc that she was running Bartab, TP *and* Sync.

The overlay issue in that bug is causing UI from many extensions to disappear.  If fixing that one doesn't fix Feedback disappearing, we should reopen this one.
Yes, after some investigation it does indeed seem they're related (or even the same). I was a bit skeptical since I couldn't reproduce bug 577349 at first.
You need to log in before you can comment on or make changes to this bug.