Closed Bug 578121 Opened 9 years ago Closed 9 years ago

REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/mozilla-central-win7-opt-u-reftest-d2d/build/reftest/tests/layout/reftests/bugs/456219-1a.html 456219-1b.html 456219-1c.html 456219-2.html

Categories

(Core :: Layout: Block and Inline, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: armenzg, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure, Whiteboard: [win7])

Attachments

(2 files)

Attached file log
After enabling reftests for Direct 2D we are hitting this failure in this test suite.
Attached file decoded failures
Untar this and open up index.html in the directory it creates to see the failures analysed.  It looks like we need to add yet more black pixels to the mask images for these tests.
heh I messed up with the summary. Fixed.
OS: Mac OS X → Windows 7
Summary: REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/mozilla-central-win7-opt-u-reftest-d2d/build/reftest/tests/layout/reftests/bugs/385569-1a.html 385569-1b.html 385569-1c.html 385569-2.html → REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/mozilla-central-win7-opt-u-reftest-d2d/build/reftest/tests/layout/reftests/bugs/456219-1a.html 456219-1b.html 456219-1c.html 456219-2.html
Armen, in future would you mind posting *raw* log excerpts (i.e. edited down from http://tinderbox.mozilla.org/$BRANCH/$CODENUMBER.gz rather than from http://tinderbox.mozilla.org/show_log.cgi?log=$BRANCH/$CODENUMBER.gz[&fulltext=1])?  The "NEXT ERROR" thingies make my reftest analysis script barf.
OK Zack. I will try to remember it.
Thanks for looking into it.
I have a script that will create the necessary black pixels...
456219-1a.html 456219-1b.html 456219-1c.html are fixed with:
http://hg.mozilla.org/mozilla-central/rev/82f84943bf00
And 456219-2.html is fixed with:
http://hg.mozilla.org/mozilla-central/rev/b5e3a1cc45f0
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Blocks: 438871
Whiteboard: [win7][orange] → [win7]
You need to log in before you can comment on or make changes to this bug.