bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Netscape 6 hang after losing network connection

VERIFIED DUPLICATE of bug 58547

Status

()

Core
Networking
P3
normal
VERIFIED DUPLICATE of bug 58547
18 years ago
18 years ago

People

(Reporter: jefft, Assigned: Gagan)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Platform: WinNT with service pack 6
ISDN connection, using DHCP

One browser window sits on http://home.netscape.com
One mail 3-pane window accessing Imap server account

Networking connection times out with an Alert modal dialog box from the browser
saying "Cannot connect to the server"

After that I was not able to dismiss the Alert dialog box nor acess the mail
3-pane window or the browser window. I cannot close the window by clicking the
"X". I can only Ctrl-Alt-Delete to get to the Task Manager and kill the
netscp6.ext process.

Re-establish the ISDN connection does not help.
Wondering about the consequence of losing slow modem ISP connection or
disconnecting the network drop.

Comment 1

18 years ago
I've sometimes run on a 28.8K modem and have seen the "cannot connect" error 
dlg, but I'm able to proceed.  It takes a little while for the error to come up, 
but I don't hang or have to ctrl-alt-del (winNT)
The App freeze because it is blocked on the PR_Wait in the function 
PL_WaitForEvent. I can reproduce the problem on Windows and Linux but 
not on Mac, you just have disconnect you PC from the net (remove the 
cable). Here is the stack:

NTDLL! 77f6829b()
KERNEL32! 77f04f41()
_PR_WaitCondVar(PRThread * 0x118b5120, PRCondVar * 0x118d8730, PRLock * 
0x118d85d0, unsigned int 4294967295) line 185 + 23 bytes
PR_Wait(PRMonitor * 0x118d9e70, unsigned int 4294967295) line 155 + 29 bytes
PL_WaitForEvent(PLEventQueue * 0x118d84d0) line 676 + 12 bytes
nsEventQueueImpl::WaitForEvent(nsEventQueueImpl * const 0x118d9eb0, 
PLEvent * * 0x1337fbe4) line 431 + 12 bytes
nsProxyObject::PostAndWait(nsProxyObjectCallInfo * 0x11cb2550) line 359 
+ 27 bytes
nsProxyObject::Post(unsigned int 13, nsXPTMethodInfo * 0x127a50f8, 
nsXPTCMiniVariant * 0x1337fca4, nsIInterfaceInfo * 0x00ab5e30) line 460 
+ 12 bytes
nsProxyEventObject::CallMethod(nsProxyEventObject * const 0x118d97d0, 
unsigned short 13, const nsXPTMethodInfo * 0x127a50f8, nsXPTCMiniVariant 
* 0x1337fca4) line 429 + 52 bytes
PrepareAndDispatch(nsXPTCStubBase * 0x118d97d0, unsigned int 13, 
unsigned int * 0x1337fd54, unsigned int * 0x1337fd44) line 100 + 31 bytes
SharedStub() line 124
nsImapProtocol::AlertUserEventUsingId(unsigned int 5053) line 3965
nsImapProtocol::OnStopRequest(nsImapProtocol * const 0x01377ef8, 
nsIChannel * 0x118dda94, nsISupports * 0x00000000, unsigned int 
2152398861, const unsigned short * 0x100a56c8 gCommonEmptyBuffer) line 1221
nsOnStopRequestEvent::HandleEvent(nsOnStopRequestEvent * const 
0x11cb2940) line 302
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x11cb2de0) line 97 + 12 
bytes
PL_HandleEvent(PLEvent * 0x11cb2de0) line 580 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x118d84d0) line 513 + 9 bytes
nsEventQueueImpl::ProcessPendingEvents(nsEventQueueImpl * const 
0x118d9eb0) line 356 + 12 bytes
nsImapProtocol::CreateNewLineFromSocket() line 3702
nsImapProtocol::EstablishServerConnection() line 928 + 8 bytes
nsImapProtocol::ProcessCurrentURL() line 1033
nsImapProtocol::ImapThreadMainLoop() line 894 + 14 bytes
nsImapProtocol::Run(nsImapProtocol * const 0x01377efc) line 694
nsThread::Main(void * 0x118b6fd0) line 84 + 26 bytes
_PR_NativeRunThread(void * 0x118b5120) line 399 + 13 bytes
_threadstartex(void * 0x118b52d0) line 212 + 13 bytes
KERNEL32! 77f04ee8()
probably a dup of bug 58547
(Reporter)

Comment 4

18 years ago

*** This bug has been marked as a duplicate of 58547 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.