With no internet connection Firefox always starts in offline mode

RESOLVED DUPLICATE of bug 720320

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 720320
8 years ago
6 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.6pre) Gecko/20100615 Namoroka/3.6.6pre ID:20100615033557

When any internet connection has been dropped and you start Firefox, you will always end up in offline mode. It also happens with network.manage-offline-status set to false. Executing the following line returns true all the time:

Cc['@mozilla.org/network/io-service;1'].getService(Ci.nsIIOService).offline

As given by Biesi this shouldn't happen. As far as I was able to search there isn't another about this problem yet.
Going to dupe this forward to bug 720320 as I didn't find this when I filed mine and bug 720320 has more information on with regards to a potential fix.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 720320
You need to log in before you can comment on or make changes to this bug.