Mail is downloaded incompletely when Windows-1251 Cyrillic letter "я" is encountered in the body.

RESOLVED INVALID

Status

Thunderbird
General
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: Konstantin Berdichevsky, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.99 Safari/533.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.10) Gecko/20100512 Thunderbird/3.0.5

Details should be evident from the below:


In the "sent" folder:

From - Mon Jul 12 15:17:58 2010
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00800000
X-Mozilla-Keys:                                                                                 
Message-ID: <4C3B6A66.1030005@comcast.net>
Date: Mon, 12 Jul 2010 15:17:58 -0400
From: panemetcirc@comcast.net
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.10) Gecko/20100512 Thunderbird/3.0.5
MIME-Version: 1.0
To: panemetcirc <panemetcirc@comcast.net>
Subject: test3
Content-Type: text/plain; charset=windows-1251; format=flowed
Content-Transfer-Encoding: 8bit

123456я789
-- 
f


On the comcast server:

Return-Path: panemetcirc@comcast.net
Received: from omta23.westchester.pa.mail.comcast.net (LHLO
 omta23.westchester.pa.mail.comcast.net) (76.96.62.74) by
 sz0147.wc.mail.comcast.net with LMTP; Mon, 12 Jul 2010 19:18:00 +0000 (UTC)
Received: from [127.0.0.1] ([76.19.169.118])
	by omta23.westchester.pa.mail.comcast.net with comcast
	id h7Hy1e0052Zcdms3j7J0B4; Mon, 12 Jul 2010 19:18:00 +0000
X-CAA-SPAM: F00000
X-Authority-Analysis: v=1.1 cv=g6iDmv6MpEJjCy7wYr9iTxtAKk6Vct76pbYNW+XvMFI=
 c=1 sm=1 a=Dyoqhi_TatcA:10 a=xDSDEXTo-cEA:10 a=Cfj4BQAnxiAA:10
 a=h9d7cPPIMR5ksCK6QzlARQ==:17 a=Cjzs2ka3sp3Fs7d4UiUA:9
 a=5Xgige7bk4xEqD0jBlG32AmcOSYA:4 a=Ft8UYL4EG9YA:10
 a=h9d7cPPIMR5ksCK6QzlARQ==:117
Message-ID: <4C3B6A66.1030005@comcast.net>
Date: Mon, 12 Jul 2010 15:17:58 -0400
From: panemetcirc@comcast.net
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.10) Gecko/20100512 Thunderbird/3.0.5
MIME-Version: 1.0
To: panemetcirc <panemetcirc@comcast.net>
Subject: test3
Content-Type: text/plain; charset=windows-1251; format=flowed
Content-Transfer-Encoding: 8bit

123456я789
-- 
f


In the "Inbox":

From - Mon Jul 12 15:18:02 2010
X-Account-Key: account6
X-UIDL: 57421.Qibf,AbxD9DY2yXcKgAHRqlTRc8=
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
X-Mozilla-Keys:                                                                                 
Return-Path: panemetcirc@comcast.net
Received: from omta23.westchester.pa.mail.comcast.net (LHLO
 omta23.westchester.pa.mail.comcast.net) (76.96.62.74) by
 sz0147.wc.mail.comcast.net with LMTP; Mon, 12 Jul 2010 19:18:00 +0000 (UTC)
Received: from [127.0.0.1] ([76.19.169.118])
	by omta23.westchester.pa.mail.comcast.net with comcast
	id h7Hy1e0052Zcdms3j7J0B4; Mon, 12 Jul 2010 19:18:00 +0000
X-CAA-SPAM: F00000
X-Authority-Analysis: v=1.1 cv=g6iDmv6MpEJjCy7wYr9iTxtAKk6Vct76pbYNW+XvMFI=
 c=1 sm=1 a=Dyoqhi_TatcA:10 a=xDSDEXTo-cEA:10 a=Cfj4BQAnxiAA:10
 a=h9d7cPPIMR5ksCK6QzlARQ==:17 a=Cjzs2ka3sp3Fs7d4UiUA:9
 a=5Xgige7bk4xEqD0jBlG32AmcOSYA:4 a=Ft8UYL4EG9YA:10
 a=h9d7cPPIMR5ksCK6QzlARQ==:117
Message-ID: <4C3B6A66.1030005@comcast.net>
Date: Mon, 12 Jul 2010 15:17:58 -0400
From: panemetcirc@comcast.net
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.10) Gecko/20100512 Thunderbird/3.0.5
MIME-Version: 1.0
To: panemetcirc <panemetcirc@comcast.net>
Subject: test3
Content-Type: text/plain; charset=windows-1251; format=flowed
Content-Transfer-Encoding: 8bit

123456

.


Reproducible: Always

Steps to Reproduce:
1. Crate an e-mail containing "я" in the body, using Windows-1251 encoding and plain text send mode.
2. Send it to yourself
3. let Thunderbird download the mail and observe that it was truncated at "я".
Actual Results:  
E-mail in the "Inbox" has a truncated body with everyting begiining with "я" substituted by spaces, a new line and a dot.
None of the attachments is downloaded either.

Expected Results:  
Full e-mail in the Inbox

The effect was  observed with two "natural" e-mails containing Cyrillic.
After that a special test e-mail was used to reproduce the bug.

Note that MS Outlook (horror!) has no problems dealing with such e-mails.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.0

Comment 1

8 years ago
Can't reproduce it, no truncated symbols. Maybe your TB Inbox get's corrupted, did you try to reindex it?
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8pre) Gecko/20100708 Lanikai/3.1.1pre.
(Reporter)

Comment 2

8 years ago
The folder has been re-indexed, and the test was repeated with the same results.

Are you sure that in your test the  parameters were the same as I described above?

Namely:

Content-Type: text/plain; charset=windows-1251; format=flowed
Content-Transfer-Encoding: 8bit

123456я789

Comment 3

8 years ago
Created attachment 457064 [details]
correct mail

Yeah, see attachment

Comment 4

8 years ago
Are you using IMAP or POP3? I believe there is incoming server involved for these problems.
(Reporter)

Comment 5

8 years ago
It's POP.

I have a suggestion: I will send my test e-mail to your shopik@inblock.ru, and you send your test e-mail to my ossifrage@comcast.net .

And then we compare the results. Deal?

Comment 6

8 years ago
Your message displayed correctly in my Inbox, no truncation.
(Reporter)

Comment 7

8 years ago
I got my test3 back from you.

It's full on the server, truncated in the Inbox.
(In reply to comment #7)
> I got my test3 back from you.
> 
> It's full on the server, truncated in the Inbox.

protocol log please ? https://wiki.mozilla.org/MailNews:Logging

Comment 9

8 years ago
Did you run any addons? If so I suggest run in safemode.
(Reporter)

Comment 10

8 years ago
Created attachment 457069 [details]
Pop3 log. includes downloading of test e-mail (about line # 6830)
(Reporter)

Comment 11

8 years ago
(In reply to comment #8)
> (In reply to comment #7)
> > I got my test3 back from you.
> > 
> > It's full on the server, truncated in the Inbox.
> 
> protocol log please ? https://wiki.mozilla.org/MailNews:Logging

Attachment  added
(Reporter)

Comment 12

8 years ago
(In reply to comment #9)
> Did you run any addons? If so I suggest run in safemode.

Did not change anything.
(Reporter)

Comment 13

8 years ago
I installed Eudora client, and it downloads the truncated version, too.

I am beginning to suspect that it's a comcast server's fault, not TB's.

I will double-check if my initial assertion that MS Outlook handled it correctly was true: I don't have MSO installed, and the person who received one of the problematic e-mails successfully might have confused Outlook with Microsoft Web mail.
(Reporter)

Comment 14

8 years ago
Outlook express truncates it, too.
(Reporter)

Comment 15

8 years ago
I started communicating with Comcast on this issue.

I guess if nobody sees a possibility of the bug being Thunderbird's, the bug should be declared invalid.

Comment 16

8 years ago
Thanks Konstantin for update, closing per your comment
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.