Autocomplete user names in the search UI

RESOLVED FIXED in Bugzilla 4.0

Status

()

RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: Ehsan, Assigned: mkanat)

Tracking

unspecified
Bugzilla 4.0
Bug Flags:
approval +
approval4.0 +
blocking4.0 +

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
+++ This bug was initially created as a clone of Bug #578253 +++

The two email address boxes in /query.cgi could probably use some autocomplete love, now that the rest of the user fields in Bugzilla have autocomplete support.

This would probably be one of the most useful things ever, since those two fields do not even do partial matches, which makes them extremely hard to use.

s/extremely hard/impossible in most cases unless you're willing to figure out that you should go somewhere else which supports partial matches, figure out the exact email address, and then come back and enter them into the field/g  :-)
(Assignee)

Comment 1

9 years ago
Those fields do do partial matches, that's what the "contains" operator is for.

This is more likely a 4.2 feature, although we do have the search field template in 4.0, so we could possibly do this.
Target Milestone: --- → Bugzilla 4.2
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> Those fields do do partial matches, that's what the "contains" operator is for.
> 
> This is more likely a 4.2 feature, although we do have the search field
> template in 4.0, so we could possibly do this.

Huh.  In the 4+ years that I've been using bugzilla on a daily basis, I had never figured that out!  I might be a dumb user, but is there any reason not to use "contains" as the default value there?  :-)

Comment 3

9 years ago
I disagree about this one. As Max says, we don't only do exact matching in these two fields (and most of my queries using them do not use exact matching). I wouldn't want Bugzilla to suggest me anything. Personally, I don't want it.
Duplicate of this bug: 578979
(Assignee)

Comment 5

9 years ago
I've thought about this, and I don't see anything wrong with at least providing the suggestions. You don't have to select them--you can just type in the field, if you want.
Flags: blocking4.0+
Target Milestone: Bugzilla 4.2 → Bugzilla 4.0
(Assignee)

Comment 6

8 years ago
Created attachment 472581 [details] [diff] [review]
v1
Assignee: ui → mkanat
Status: NEW → ASSIGNED
Attachment #472581 - Flags: review?(guy.pyrzak)

Updated

8 years ago
Attachment #472581 - Flags: review?(guy.pyrzak) → review+
(Assignee)

Updated

8 years ago
Flags: approval4.0+
Flags: approval+
(Assignee)

Comment 7

8 years ago
Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/trunk/                       
modified template/en/default/search/form.html.tmpl
Committed revision 7474.

Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/4.0/                         
modified template/en/default/search/form.html.tmpl
Committed revision 7403.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.