Favicon in Fox does not respond to new favicon stored on site

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: educmale, Unassigned)

Tracking

3.6 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2012-07-08])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6

I changed the favicon.ico graphic on my website, and Fox will not use the new icon.

The icon -does- populate with the new icon if I look at the site content, as mirrored locally, using Fox.   My local home page [a separate html page] also uses the new, locally stored favicon.ico file, and that works.

The new one also shows up in MS IE, locally and on the website.

In an effort to isolate what is going on with FOX, I tried these steps:

1.  Deleted the ico file outright, on the web site.  Fox still reports the old icon.  [odd, that!, especially since the new icon is seen by IE, so the site and my ISP aren't caching something, somewhere, I suppose...]
2.  Deleted all history references to the site's pages in Fox, hoping this would force use of the new icon.
3.  Removed the site's references from the "Most Visited" Tab
4.  Used the "forget about this site" and the delete, inside bookmarks where I found any reference to the site.   [What is the difference between "Forgetting" and "Deleting", anyway?  They both seem to delete a single bookmark, anyway...]
5.  Closed/restarted Fox after the above items...

Site and Icon: WWW.ComplianceOfficer.Com/favicon.ico

Where does Fox store the reference to the old icon?

Reproducible: Always



Expected Results:  
I should see the new icon.
(Reporter)

Comment 1

8 years ago
Reporting that approximately 1hour later, the icon showed up, as intended.   Which makes me wonder if 

a) it was a Mozilla thing, where I deleted the bookmarked references, and restarted, and then it worked [though I missed that as a fix...] or...

b) some other quirk arising from my machinations in attempting a fix managed to quell the old icon; or,

c) there is a cache out there, somewhere, between my ISP and the site's server, which caches different things to different browsers...?


In the case of a) or b), shouldn't the change be recognized by my local fox sooner?

In the case of c) . . . how curious.
what are the headers for this file send by the server ?
The caching depends on the http headers.

Did you clear the disk cache ?
Do you saw the old favicon in the bookmarks or in the URL bar ?
(Reporter)

Comment 3

8 years ago
Thanks for looking in on this...

I did not clear the disk cache, locally.   I saw the old icon everywhere, bookmarks, tabs, and the location bar.

I have no idea what the headers are, but I suspect that they are identical, now, as before, and could be retrieved by you or anyone [I wouldn't know how, just now...]

In your second line, you say that the caching depends on the HTTP headers...do you mean my local cache in fox, or the caching at the ISP or Domain Provider levels?

I am tempted to make a minor modification to the icon, and see how it reverberates in Fox.   But I still don't know where the Favicon is cached, locally on my machine, and what trigger[s] there are to force a new lookup over the web [if, indeed] it is Fox, locally causing this artifact and not ISP/Server Caching]
images are stored in the disk cache (look in about:cache) and the disk cache is part of Gecko. 
Why should it matter if they are different or not now.
The headers that are sent by the server during the image retrieval specify the expire time in the cache.
There is in most cases no other caching involved unless you configured a proxy server.
You can use shift+reload to bypass any caching.

Updated

8 years ago
Version: unspecified → 3.6 Branch

Comment 5

6 years ago
can you stilll reproduce?
Whiteboard: [closeme 2012-07-08]
(Reporter)

Comment 6

6 years ago
i would mark it as confirmed/resolved [by the new update]...as all icons now show properly.

realistically, to test it, i would have to rewrite/redraw all the favicons.
thanks for the response, marking wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.