cfx testall fails on Linux system

RESOLVED FIXED

Status

RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: ashah, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 457099 [details]
Test failure log

See log attached.
Ran the tests on Ubuntu 10.04 LTS.
Attachment #457099 - Attachment mime type: application/octet-stream → text/plain
Thanks Ayan, these reports are useful.  However, in the future it would help us a lot if you could:

1. Note the exact command line you ran that generated the log.

2. Note the exact version of the Jetpack SDK you used (0.5 release, a changeset in the repo, etc.).  Actually, please only run your tests against the current tip changeset in the repo.  If you need help doing that, please let us know.

3. Instead of filing one "tests failed" bug, please try to look at the individual failures in your log.  You can search Bugzilla to see if any of the failures are known.  If they're not known, you can file separate bugs for each.  I understand that this might be difficult sometimes, and certainly one "tests failed" bug is better than no bug at all.

OK, here are the failures in the log:

1. doctest failure, should be fixed by bug 567888

2. Many "ubufox" failures (what's ubufox?)

console: [JavaScript Error: "labelGetUbuntu is null" {file: "chrome://ubufox/content/overlay.js" line: 82}]
console: [JavaScript Error: "labelGetUbuntu is null" {file: "chrome://ubufox/content/overlay.js" line: 82}]
console: [JavaScript Error: "labelGetUbuntu is null" {file: "chrome://ubufox/content/overlay.js" line: 82}]
console: [JavaScript Error: "labelGetUbuntu is null" {file: "chrome://ubufox/content/overlay.js" line: 82}]
...

3. Many private browsing test failures that look a lot like bug 565338

4. nsIObserverService-related errors that look like bug 575147
(In reply to comment #1)
> 2. Many "ubufox" failures (what's ubufox?)

I believe these are caused by a bug in the "ubufox" addon that Ubuntu installs in a system-wide location, so it automatically loads into any new profile you create.  One way to get rid of the errors is to disable the addon in the profile you use for testing.  That requires you to reuse the same profile for testing via the --profiledir flag.
(Reporter)

Comment 3

9 years ago
(In reply to comment #1)
 
> 1. Note the exact command line you ran that generated the log.
   The command I ran was 'cfx testall'

> 2. Note the exact version of the Jetpack SDK you used (0.5 release, a changeset
> in the repo, etc.).  Actually, please only run your tests against the current
> tip changeset in the repo.  If you need help doing that, please let us know.
  I ran the test against the jetpack-sdk-latest.zip available on the ftp website. It was jetpack-sdk-0.5

 
> 3. Instead of filing one "tests failed" bug, please try to look at the
> individual failures in your log.  You can search Bugzilla to see if any of the
> failures are known.  If they're not known, you can file separate bugs for each.
>  I understand that this might be difficult sometimes, and certainly one "tests
> failed" bug is better than no bug at all.
   
   Sure.! I will try to look for them.
The Add-on SDK is no longer a Mozilla Labs experiment and has become a big enough project to warrant its own Bugzilla product, so the "Add-on SDK" product has been created for it, and I am moving its bugs to that product.

To filter bugmail related to this change, filter on the word "looptid".
Component: Jetpack SDK → General
Product: Mozilla Labs → Add-on SDK
QA Contact: jetpack-sdk → general
The failures that can be fixed have been fixed, the ubufox ones are kinda beyond our scope. -> FIXED!
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.