Firefox will not allow another instance to start up

RESOLVED INVALID

Status

()

--
enhancement
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: chris, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6 ( .NET CLR 3.5.30729)

Firefox will not allow another instance to start up, even when there is no profile conflict as reported in bug #462311.

I mostly experience this while using "portable" Firefox from portableapps.com, which I use for testing multiple browsers without having to install them all (and all their versions) simultaneously.

While running a standard install of Firefox 3.6 (for instance), I cannot launch the 4.0-beta as a portable app because the 3.6 version is detected as already-running.

Would it be possible to allow multiple Firefox instances if there is no profile conflict?

Reproducible: Always

Steps to Reproduce:
1. Launch Firefox x
2. Launch Firefox y (either "portable" or even just to load a different profile)
Actual Results:  
"Another instance is already running" message

Expected Results:  
Second copy of Firefox running under another profile
See the 'no-remote' command-line information here, it will allow you to run more than one instance.

http://kb.mozillazine.org/Command_line_arguments
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

9 years ago
Hmm... didn't know about "no-remote" (simply using -ProfileManager on my main ff install doesn't work: -no-remote is also required in order to pull-up the profile manager if one instance is already running).

I tried this with "portable" Firefox and it appears that the command line arguments either aren't being passed-through to firefox.exe, or the portable wrapper is modifying them in an incompatible way.

I'll check to see what's going on, there. Thanks for the tips.
(Reporter)

Comment 3

9 years ago
For the edification of the community, this was a problem with PortableFirefox, not Firefox itself. pff checks to see if "firefox.exe" (or something similar) is already running and prevents a second instance from running /within the wrapper itself/.

Adjusting the .ini file that ships with PortableFirefox to set "AllowMultipleInstances=true" will remove pff's check and allow it to start up as desired.

Apologies for the noise in bugzilla. Keep up the great work!
You need to log in before you can comment on or make changes to this bug.