If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

sorting order in buglist.cgi is inconvenient

RESOLVED DUPLICATE of bug 23473

Status

()

Bugzilla
Query/Bug List
P3
enhancement
RESOLVED DUPLICATE of bug 23473
17 years ago
5 years ago

People

(Reporter: Nick Hibma, Assigned: Dawn Endico)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
If the sorting order is inverted it means that the most recent bugs, most 
important bugs, etc. are mentioned at the top of the page which makes them more 
'in your face'.

Patch against today's bugzilla in the URL.

Updated

17 years ago
Whiteboard: 2.14 → 2.16
moving to real milestones...
Target Milestone: --- → Bugzilla 2.16

Comment 2

17 years ago
Created attachment 26540 [details] [diff] [review]
the mentioned patch, just in case ...

Comment 3

16 years ago
-> Bugzilla product, Buglist component, reassigning.
Assignee: tara → endico
Component: Bugzilla → Query/Bug List
Keywords: review
Product: Webtools → Bugzilla
Whiteboard: 2.16
Version: other → unspecified
Do we want to do this, or do we want to make it so clicking the column again
sorts the other way, or something? That should be pretty trivial...

Gerv
We are currently trying to wrap up Bugzilla 2.16.  We are now close enough to
release time that anything that wasn't already ranked at P1 isn't going to make
the cut.  Thus this is being retargetted at 2.18.  If you strongly disagree with
this retargetting, please comment, however, be aware that we only have about 2
weeks left to review and test anything at this point, and we intend to devote
this time to the remaining bugs that were designated as release blockers.
Target Milestone: Bugzilla 2.16 → Bugzilla 2.18

Comment 6

16 years ago
I've seen a couple of other installations that had reverse sorting
functionality. I think it is the bugzilla at ActiveState that does this the
best. They have a little triangle icon next to each column name and it points in
the direction of the sort. To reverse the sort on that column you click the
column header link and the sort reverses and the triangle icon is inverted. See
http://bugs.activestate.com/buglist.cgi?bug_status=UNCONFIRMED for an example.

Comment 7

16 years ago
The patch is so old that it practically doesn't exist; duping to bug 23473 which
has some implementation notes and a bit more activity.

*** This bug has been marked as a duplicate of 23473 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
clearing target in DUPLICATE/WORKSFORME/INVALID/WONTFIX bugs so they'll show up
as untriaged if they get reopened.
Target Milestone: Bugzilla 2.18 → ---
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.