SM 2.1a2 doesn't remove extensions installed in the applications folder

RESOLVED WONTFIX

Status

()

Toolkit
Add-ons Manager
RESOLVED WONTFIX
8 years ago
7 years ago

People

(Reporter: godzfire, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [AddonsRewrite])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a6pre) Gecko/20100629 SeaMonkey/2.1a2
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a6pre) Gecko/20100629 SeaMonkey/2.1a2

It seems with the change of the new addon manager in SM 2.1a2, that something got broke where you now cannot uninstall/remove certain extensions; ChatZilla, DOM Inspector, Javascript Debugger, and SM Debug And QA UI in particular. Every version prior to this you were able to uninstall them, which I personally do to remove features/bloat from the program I don't use.

http://forums.mozillazine.org/viewtopic.php?f=5&t=1943783&sid=64c6235c2684f4fa15d306b2315a8abf

Reproducible: Always

Steps to Reproduce:
1. Download SM 2.1A2
2. Try to use the Addon Manager to uninstall the listed extensions



http://forums.mozillazine.org/viewtopic.php?f=5&t=1943783&sid=64c6235c2684f4fa15d306b2315a8abf
These extensions that you can't uninstall are those that come bundled with the Suite. Neither can you uninstall the SeaMonkey default and Modern themes, even after installing and using a different theme.

All this is part of the new addons manager, and I suspect that it is intentional. I'm confirming this bug for now because I can reproduce it, but its final disposition might quite well be INVALID (i.e. "this behaviour is intentional").

I'm using:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:2.0b2pre) Gecko/20100701 Lightning/1.1a1pre SeaMonkey/2.1a3pre - Build ID: 20100701101320
Status: UNCONFIRMED → NEW
Component: General → Add-ons Manager
Ever confirmed: true
OS: Mac OS X → All
Product: SeaMonkey → Toolkit
QA Contact: general → add-ons.manager
Hardware: x86 → All
Whiteboard: [AddonsRewrite]
Version: unspecified → Trunk
(Reporter)

Comment 2

8 years ago
Strange that I've never had a problem uninstalling them from previous versions of SeaMonkey, as shown in this post: http://forums.mozillazine.org/viewtopic.php?p=9617639#p9617639

Personally I don't see how removing this ability to uninstall extensions is an improvement.
(In reply to comment #2)
> Strange that I've never had a problem uninstalling them from previous versions
> of SeaMonkey, as shown in this post:
> http://forums.mozillazine.org/viewtopic.php?p=9617639#p9617639
> 
> Personally I don't see how removing this ability to uninstall extensions is an
> improvement.

That picture was taken with the old addons manager, which existed in SeaMonkey from Sm 2.0a1pre to Sm 2.1a1, and in Firefox and Thunderbird for as long as I can remember. The addon manager interface was totally rewritten starting at SeaMonkey 2.1a2pre and at the corresponding versions of Firefox and Thunderbird, and it is this new addons manager which (at the moment, at least) cannot uninstall addons packaged with the application.
Oops: i meant: all pictures except the rightmost one were taken, etc.
Yes, we do not want to support removing of global extensions via the add-ons manager. Most of the times users will not have the permissions to do that. You can still go to the application folder and remove those extensions via your file manager. Also in some situations users weren't aware that they remove extensions which will affect all other users on that system. 

Dave, can we mark it as invalid?
Summary: SM 2.1a2 doesn't remove extensions → SM 2.1a2 doesn't remove extensions installed in the applications folder

Comment 6

7 years ago
This won't be fixed, and I don't think we even supported that in previous versions, IIRC, the "Remove" button was disabled there.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 7

7 years ago
Ahem: http://forums.mozillazine.org/viewtopic.php?p=9617639#p9617639

Look at the pictures.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 8

7 years ago
Interesting. It still won't be fixed.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.