INBOX index corruption

VERIFIED WORKSFORME

Status

P3
normal
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: bobj, Assigned: Bienvenu)

Tracking

Trunk
x86
Other

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
2000-10-20-17-MN6 on US Win95

Filing a message from Trash to INBOX corrupted the INBOX.msf index file.

I accidentally deleted a message from my IMAP INBOX, so I
(1) opened the deleted message from the IMAP Trash folder
(2) used the File button to move the message back to IMAP INBOX folder

but the message was not listed in my INBOX.  I tried sorting by subject, by
date, and by subject again.  I did a search of INBOX.  I searched Trash and it
was not there either.  I opened mail from NS4.75 and the message was in fact
in my INBOX!

(3) back in NS6, I did a File|Compact This Folder

now my INBOX showed only 2 messages (not 1500+ messages).  One of the 2
messages was the missing message that I moved from Trash to INBOX!  I clicked
on Get Msg and got 2 new messages for a total of 4.

I quit and restarted mail.  I quit and restarted NS6, and reopened mail.
No change either time.

I quit NS6, renamed INBOX.msf, restarted NS6, opened mail, clicked on INBOX,
and then it rebuilt the INBOX index correctly.

This is pretty bad, if a user cannot recover messages from the Trash without
having to quit and remove
   C:\Windows\Mozilla\Users50\<profile>\ImapMail\<IMAP-host>\INBOX.msf
(Assignee)

Comment 1

18 years ago
I tried these steps. It worked fine for me. The message I filed/moved back to
the inbox from the trash was in the inbox. So I don't know how to reproduce this
problem. I've never seen it either.
Status: NEW → ASSIGNED

Comment 2

18 years ago
(1) opened the deleted message from the IMAP Trash folder
(2) used drag & drop to move the message back to IMAP INBOX folder

In my case, I see 2 messages for 1 message which was copied from the trash.

I used win32 branch build 2000-10-24-09-MN6.
(Reporter)

Comment 3

18 years ago
hmmph.   I just tried with the same build and could not reproduce this.

Since I logged this bug from memory, one thing that I may have done different
than originally described, is that I might have left my INBOX open, searched
Trash for the message I wanted back, opened it from the search dialog and
then filed it back to INBOX.  But I tried to reproduce it that way too and
could not cause the problem...
(Assignee)

Comment 4

18 years ago
I couldn't reproduce what nhotta saw either - I only see one copy of the message
I drag dropped from the trash back to the original folder.

Comment 5

18 years ago
esther - can we try to reproduce this also?  This would be a bad bug to have 
around if reproducible.

Comment 6

18 years ago
I couldn't reproduce this bug using today's branch build on Win NT.

Comment 7

18 years ago
I couldn't reproduce this using today's branch build on Win 2000.
(Assignee)

Comment 8

18 years ago
I'm going to mark works for me since no one can reproduce this. please re-open
if you see it again.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 9

18 years ago
Marking verified (worksforme). No response since November.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.