ThunderBird 3.1 inserts a blank character (0x20) to the top of email body

RESOLVED DUPLICATE of bug 564737

Status

defect
--
trivial
RESOLVED DUPLICATE of bug 564737
9 years ago
9 years ago

People

(Reporter: vuhung16plus, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; vi; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9.2.4) Gecko/20100608 Lightning/1.0b2pre Thunderbird/3.1

ThunderBird 3.1 inserts a blank character (0x20) to the top of email body

Reproducible: Always

Steps to Reproduce:
1. Compose an email
2. Type "Test" or "To:" or "BCC:" in the content of the email
3. Hit "Send" (to send to myself, ThunderBird 3.1 is used as sending mailer and receiving mailer)
4. Check the incoming email. 
Actual Results:  
There is an unexpected space (0x20) before "Test" or "To:" or "BCC:" in the body of the email received. 

Expected Results:  
5. There is a 0x20 before "Test"
6. There is a 0x20 before "To:" or "BCC:" (acceptable)

From - Wed Jul 14 12:40:56 2010
X-Account-Key: account2
X-UIDL: UID44696-1257123930
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
X-Mozilla-Keys:                                                                                 
Return-Path: <vuhung@vinicorp.com.vn>
Received: from www908.sakura.ne.jp (ksav61.sakura.ne.jp [219.94.192.141])
	by www908.sakura.ne.jp (8.14.3/8.14.3) with ESMTP id o6E5dNXN067103
	for <vuhung@vinicorp.com.vn>; Wed, 14 Jul 2010 14:39:23 +0900 (JST)
	(envelope-from vuhung@vinicorp.com.vn)
Received: from [192.168.52.16] (localhost [117.1.232.45] (may be forged))
	(authenticated bits=0)
	by www908.sakura.ne.jp (8.14.3/8.14.3) with ESMTP id o6E5dLLv067090
	for <vuhung@vinicorp.com.vn>; Wed, 14 Jul 2010 14:39:21 +0900 (JST)
	(envelope-from vuhung@vinicorp.com.vn)
Message-ID: <4C3D4DE5.5090008@vinicorp.com.vn>
Date: Wed, 14 Jul 2010 12:40:53 +0700
From: "Nguyen Vu Hung (VNC)" <vuhung@vinicorp.com.vn>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9.2.4) Gecko/20100608 Lightning/1.0b2pre Thunderbird/3.1
MIME-Version: 1.0
To: Nguyen Vu Hung <vuhung@vinicorp.com.vn>
Subject: test
Content-Type: multipart/alternative;
 boundary="------------060205010902040901050903"
X-Anti-Virus: K-Prox Anti-Virus Powered by Kaspersky, bases: 14072010 #3973965, status: clean

This is a multi-part message in MIME format.
--------------060205010902040901050903
Content-Type: text/plain; charset=UTF-8; format=flowed
Content-Transfer-Encoding: 7bit

  test



http://tools.ietf.org/search/rfc4155

<quote>
  Many implementations are also known to escape message body lines
that
   begin with the character sequence of "From ", so as to prevent
   confusion with overly-liberal parsers that do not search for full
   separator lines.  In the common case, a leading Greater-Than symbol
   (0x3E) is used for this purpose (with "From " becoming ">From ").
   However, other implementations are known not to escape such lines
   unless they are immediately preceded by a blank line or if they
also
   appear to contain an email address and a timestamp.  Other
   implementations are also known to perform secondary escapes against
   these lines if they are already escaped or quoted, while others
   ignore these mechanisms altogether. 
</quote>
Group: core-security

Comment 1

9 years ago
Pretty sure this is a dup
Whiteboard: dupeme
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 564737
(In reply to comment #1)
> Pretty sure this is a dup

Indeed :-)
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.