line-height needs to use rounded value

RESOLVED DUPLICATE of bug 442139

Status

()

RESOLVED DUPLICATE of bug 442139
8 years ago
8 years ago

People

(Reporter: jtd, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 457271 [details]
testcase, animate line-height from <1em to >1em

We appear to be placing text lines using multiples of the raw line-height value rather than the rounded value.  In other words, the calculation appears to be:

  y = round(line-height * # lines)

rather than 

  y = round(line-height) * # lines

The effect of this difference is that it produces gaps and unevenness when rendering lines of text with line-heights that don't convert to integer pixel values.  When the attached testcase is run, you'll see gaps at different places as the line-height is varied by amounts < 1px.

Originally posted on Typophile:
http://www.typophile.com/node/72215

Comment 1

8 years ago
This bug is old and has duplicates
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 442139
You need to log in before you can comment on or make changes to this bug.