hangs if you are dragging a tab when an alert fires

RESOLVED DUPLICATE of bug 100180

Status

()

Firefox
Tabbed Browser
--
critical
RESOLVED DUPLICATE of bug 100180
8 years ago
8 years ago

People

(Reporter: js.email, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6 ( .NET CLR 3.5.30729)

Hangs if you are dragging a tab when an alert fires.

Reproducible: Always

Steps to Reproduce:
1. Create a page that displays an alert after given number of seconds
2. Create an index page with a link to the first one
3. Open the index page, open the link in a new tab and start dragging the tab around the screen until you receive the alert
Actual Results:  
The browser hangs and there`s no way to close it(or to do anything else). If you close it from the Task Manager(from the Application tab!) the small image ,of the page that you were dragging around, remains on the screen and sometimes even continues to follow the cursor, despite that the browser was closed.

NOTE: I marked it critical, because the browser doesn`t recover my tabs after I close it.

Expected Results:  
The tab should have remained were it originaly was and the user should have been given the chance to click the alert.
After the alert is gone, the user can then (again) try to move the tab.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 100180
You need to log in before you can comment on or make changes to this bug.