Closed Bug 578668 Opened 9 years ago Closed 9 years ago

First paragraph of non-html email gets erroneously indented

Categories

(Thunderbird :: Message Compose Window, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 564737

People

(Reporter: benjamingslade+mozilla, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.6) Gecko/20100625 Firefox/3.6.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.4) Gecko/20100608 Thunderbird/3.1

If you're setup to send html email, but send an email with no html formatting, thunderbird automatically sends it as "Content-Type: text/plain;" and "Content-Transfer-Encoding: 7bit".   For emails sent this way, the first paragraph is erroneously indented.  "first paragraph" here means the first line in the composed email until an explicit enter/return character is typed.

Reproducible: Always

Steps to Reproduce:
1. Under Tools->Options->Composition->Send Options..->Text Format
   select "Send the message in both plain text and HTML"
2. On that same window, make sure there are no "HTML domains" 
   and no "Plain Text Domains" entered (or at least not the domain your
   using to run this test)
3. Under Tools->Account Settings, select the "Composition and Addressing"
   list item for the mail server you're using for the test.  Make sure
   "Compose messages in HTML format" is checked.
4. Send an email with no HTML formatting (eventhough the HTML formatting
   options will appear in the compose email window).   The email should
   contain two lines with no leading spaces (in the compose window)
Actual Results:  
Actual results:
The first line will be erroneously indented by one space.
(The email should be sent with the header lines "Content-Type: text/plain;" and "Content-Transfer-Encoding: 7bit")


Expected Results:  
Expected results:
The first line should not be indented.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 564737
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.