Closed Bug 578679 Opened 10 years ago Closed 10 years ago

on desktop linux, about:config doesn't display in the browser window

Categories

(Firefox for Android Graveyard :: General, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jmaher, Assigned: vingtetun)

References

Details

Attachments

(1 file)

I downloaded the latest build today from:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mobile-trunk/fennec-2.0a1pre.en-US.linux-i686.tar.bz2

(no option to cut+paste from about:, so here is my build info):
Version=2.0a1pre
BuildID=20100714021610
SourceRepository=http://hg.mozilla.org/mobile-browser
SourceStamp=1eb35d99a861

When loading about:config, it doesn't display any errors, but does show what looks to be an accurate thumbnail in the tab strip.  the problem is the browser view window is empty (blank white)
Attached patch PatchSplinter Review
This prevent having 0 as the result of viewportRect.right for xul pages (and for any other type of pages)
Attachment #457306 - Flags: review?(mark.finkle)
Comment on attachment 457306 [details] [diff] [review]
Patch

A comment would be nice to add when you check this in.
Attachment #457306 - Flags: review?(mark.finkle) → review+
http://hg.mozilla.org/mobile-browser/rev/c8ccfa363542
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Duplicate of this bug: 578836
Duplicate of this bug: 578936
Joel, vlad, can you please verify this bug is fixed on latest nightlies?  Thanks.
I have checked about:config on Maemo5 device with an gtk build with the following dates: 
-20100727005730
-20100728005450

Config page loads, but I cannot manage to scroll it down properly. The last "Preference" I see is accesibility.tabfocus. When searching for other preferences(from page search dialog), page echoes only 6 of the matching results.
And another thing, be sure to open about:config in the default tab (first tab), since for other tabs the bug is regressive and blank page is displayed
The panning problem is a different bug. No XUL or <iframe>s or scrollable <div>s will pan in content.
Try opening about:config or other system pages in another tab than the default one. See how this action creates another empty tab in background. I was just about to file this problem but I seem to have trouble with bugzilla.
verified FIXED on builds:
Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:2.0b4pre) Gecko/20100811 Namoroka/4.0b4pre Fennec/2.0a1pre

and

Mozilla/5.0 (Android; U; Linux armv71; en-US; rv:2.0b4pre) Gecko/20100811 Namoroka/4.0b4pre Fennec/2.0a1pre
Status: RESOLVED → VERIFIED
bugspam
Assignee: nobody → 21
You need to log in before you can comment on or make changes to this bug.