In editor, scrolling doc displays duplicate I beam carets when typing

VERIFIED FIXED in M11

Status

()

Core
Editor
P3
normal
VERIFIED FIXED
19 years ago
17 years ago

People

(Reporter: Chris Petersen, Assigned: Simon Fraser)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Version: Apprunner
Build: April 29th Build (1999042908)
Platform: All
Expected Results:After scrolling the document, only one I beam cursor should be
displayed.
What I got: When typing after scrolling the document, two I beam cursors are
displayed.
Steps to reproduce:
1) Launch Apprunner.
2) From the Tasks menu, select the Editor menu.
3) Partially scroll the document
4) Now, click in the document as start typing. Notice two I baem cursors are
displayed.

Updated

19 years ago
Assignee: kostello → sfraser
Target Milestone: M6

Comment 1

19 years ago
Reassigning to Simon Fraser, setting milestone to M6
(Assignee)

Updated

19 years ago
Target Milestone: M6 → M7
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

19 years ago
Minor cosmetic thing. M7.
(Assignee)

Comment 3

19 years ago
*** Bug 6687 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

19 years ago
*** Bug 5977 has been marked as a duplicate of this bug. ***

Updated

19 years ago
QA Contact: 4079 → 4144

Comment 5

19 years ago
assigning qa_contact to Chris Petersen

Updated

19 years ago
Summary: In editor, scrolling the document displays dupilcate I beam cursors when typing.. → In editor, scrolling doc displays duplicate I beam cursors when typing
Target Milestone: M7 → M9

Comment 6

19 years ago
move to M9 per 6/15/99 meeting

Updated

19 years ago
Summary: In editor, scrolling doc displays duplicate I beam cursors when typing → In editor, scrolling doc displays duplicate I beam carets when typing

Comment 7

19 years ago
fix summary
(Assignee)

Updated

19 years ago
Target Milestone: M9 → M10
(Assignee)

Comment 8

19 years ago
Cosmetic. M10. The problem happens when we get a refresh on updating the window;
I get passed a rendering context that has a different coordinate system. Not
quite sure how to fix this yet.
(Assignee)

Updated

19 years ago
Target Milestone: M10 → M11
(Assignee)

Comment 9

19 years ago
M11
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

19 years ago
Caret fixes checked in. Please reopen if you continue to see problems.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 11

19 years ago
With the Sept 16th build, this problem appears to be fixed.
You need to log in before you can comment on or make changes to this bug.